Emlid RS2+ keeps disconnecting from WiFi

I’m experiencing issues with the WiFi hotspot of the RS2+. The hotspot keeps disconnecting from my Android phones (Samsung S20 and XcoverPro). When it’s connected, the Flow app sometimes manages to make a connection, but this only lasts for a few minutes. Most of the time the IP address is visible in the list of devices, but when I try to connect is says: “Can’t connect to Reach”.

I was hoping a firmware update might fix it, but it is still present in 31 beta 3. I also already checked the battery optimization settings of both phones. I don’t have these issues with my other RS2 (non-plus) receivers.

Any idea?

1 Like

My suggestions : rollback to a stable firmware version, deactivate mobile data and bluetooth when connecting to the Reach’s hotspot, and, if you have any VPN activated on your phone, disconnect it.

1 Like

Hi Florian,
I tried this, but unfortunately it didn’t help. I’m not using a VPN.

Hi Sean,

Is there a SIM card in the Reach RS2+? If so, can you please check if the same behavior repeats when you take it out?

Without the SIM inserted I don’t have these issues. It’s connects right away via the hotspot and stays connected. Also when I reboot Emlid Flow it finds the RS2+ right away.

How can I make this work the same way with the SIM inserted?

Hi Sean,

Please disable the Share mobile data from Reach in hotspot mode option in the Mobile data settings and let me know if it works for you.

Disabling the data sharing option doesn’t make a difference.
I tried again with mobile data turned off (as suggested by Florian earlier). I do think that resolves the problem. That gives the same result as taking out the SIM completely. So to summarize:

When I take SIM out of the Emlid: No connection issues
When the SIM is inserted and I turn the mobile data of the Emlid off: No connection issues
When SIM is inserted, mobile data turned on, data sharing on: Connection issues.
When SIM is inserted, mobile data turned on, data sharing off: Connection issues.

1 Like


I see, thank you for the summary! Can you please share a Full System report from your Reach? I’ll check it to see what we can do. The report can contain personal data, so I’d recommend sending it to support@emlid.com.

I am having the same EXACT issues with my android devices. It doesn’t matter the brand, (IE Samsung, Motorola, etc.) all of my android devices. If I cant get the mobile data to share to my tablet or other android device…what is the sense in my purchase of the RS2+ With all the “work arounds” I can achieve the same results with the RS2 for hundreds of dollars less!!! It seems as though the RS2+ is only IOS friendly…EXTRETEMLY DISSAPPOINTED with this purchase!

I also experience these problems. But not only with the RS2+, also with the RS2. Also with multiple (Android) phones and tablets.

To me it feels some instability has been introduced in the newer firmware. We have 6 antennas, of which 4 were bought recently. But with it the current issues I doubt why I selected these antennas. In my memory we didn’t have as much problems last two years.

Another issue is that some (RS2+) antennas are not discovered by the Flow app. This happens even while connected to the antenna’s hotspot. Entering the IP-address works to get access to the Reach panel.

Hi Sean,

I’ve looked into it with our devs. In some rare cases, the receiver’s hotspot connection may become unstable when there’s a SIM card inside. For now, the reasons are not fully clear, but we continue the investigation. Still, such behavior is hard to reproduce, so the research takes time. Once there are any updates, I’ll let you know.

For now, we can suggest connecting to Reach via Bluetooth as described in this thread. The Bluetooth connection is in Beta, but it may help work with a SIM card in your situation.

If it doesn’t work for you, you can also use the NTRIP over Bluetooth option or connect Reach to a mobile hotspot or a Wi-Fi network.

Hi Bram,

Another issue is that some (RS2+) antennas are not discovered by the Flow app. This happens even while connected to the antenna’s hotspot. Entering the IP-address works to get access to the Reach panel.

Please check that the mobile data is turned off on your Android device and that the Battery optimization is disabled for Emlid Flow. If it doesn’t help, please create a new thread or write us to support@emlid.com, just to keep the topics separate. We’ll check how we can help.

Hi Kseniia,

Any update on this one? We need the SIM inserted in the RS2+ in our use (as a reference with NTRIP via the caster). The bluetooth connection doesn’t allow to change all the settings.

Please fix this soon.

Hi Sean,

There’s no news I can share now, but we are looking into the possible options. Still, finding a solution for this issue requires thorough research, so it’ll take some time. Once there are any updates, I’ll be sure to let you know.

A post was split to a new topic: RS2+ keeps disconnecting from internet

Hello, I am also having the same issue.
This is a new issue as my Reach RS2+ has been not giving problems until now.

Any fix yet?


Hi Nicolas,

We don’t have any updates to share at this time, but we are researching potential solutions. I’ll keep you updated once there are any developments. Can you confirm that your issue is that you can’t connect to the Reach hotspot if a SIM card is inside?

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.