RS2+ keeps disconnecting from internet

We are experiencing the same problems with our new RS2+. No issues with all the other Emlid receivers we have.

A solutions is much appreciated as the unit is unusable until this problem is sorted.

RS2+ tested without any networks, only hotspot, no SIM installed and connected to Android device. Still the same, connection keeps falling out constantly.

Tried to stake out 5 points today and after 3 hrs of connection and disconnection I managed to complete all 5 fixes :face_with_diagonal_mouth:

Hi @Spipp,

Welcome to the forum!

Since you don’t have a SIM card installed on your receiver, I’d like to investigate your problem further.

Does Reach only disconnect from the internet when using an Android hotspot? If so, please check the following points:

  • Is your hotspot working at 2.4GHz?
  • Does your connection fail when you’re connected to Wi-Fi?

You mentioned that there are no issues with other Emlid receivers. Can they connect to the same Android hotspot in the same area?

1 Like

A post was split to a new topic: RS2+ disconnects from hotspot


Apologies for being away for quite some time.

We have used the RS2+ with 4G on a few projects lately and it seems to work fine. I think the initial issue was several units trying to connect to the receiver. It was 2x phones and a tablet with the Hotspot saved.
After removing all the hotspots and with only a single aneroid phone dedicated to the RS2+ it looks like normal behaviour. We have not experienced any unusual frequent disconnects.

We are now really happy with the RS2+!

1 Like

Thank you for the update, and I’m glad you’re able to connect now!