Emlid Raspbian OS no booting on RPI 4 2GB

Hello everyone.

I have a problem with my RPI 4 2GB.
Emlid Raspbian Buster OS (latest, i download it from Navio2 docs) not working on RPI4 board but other OS is working perfectly. Green LED is blinking 4 long and 4 short times, its mean unsupported board. Can you help me please solve it ?

I think problem is kernel version.

Need update emlid OS for Raspberry Pi 4 rev 1.5 (latest version and bootloader)

Hi Mike,

Thanks for your patience!

Do you receive any messages during the boot? Has it worked with your RPi 4 before, or was it like this from the very beginning?

This is my first time using RPI but I have worked with linux. I bought it a few weeks ago, but as I understood emlid OS does not work on rev 1.5 … And I broke my RPi, tried to install the old bootloader, after which the board does not work, I think the sd card slot does not work, I tried to restore the bootloader through Rpi imager , but doesn’t work.

Okay, I have another RPi 4 2gb rev 1.5… can you compile emlid linux for this board?


Some boards currently have issues with the correct booting, indeed. Our devs are looking into it, but it will take time to implement the compatibility of such boards. Once I have any news, I’ll let you know.

If you have another RPi board, say, RPi 3, it should work fine with the Navio2 image.

Ok thanks, no i dont have rpi 3… Latest Raspbian Buster is working fine… is it possible to install all components on this OS

Or can you compile new OS for RPI 4 rev 1.5 (latest bootloader) please :hugs:

Hi Mike,

Navio2 requires RCIO code which is not an open-source code, so it’s hardly possible to do that manually.

Our devs team is currently looking into what might be the best solution here. It requires some time as there are a lot of aspects that we need to check to understand what went wrong. Surely, when there’s any update, I’ll let you know!

approximately when will it be ready?

Hi Mike,

The work on the issue is still in progress. I can hardly give any approximate dates, but I’ll let you know if there’s any news.

2 posts were merged into an existing topic: Image problem

Hi, any news, when will be ready stable version ? :slightly_smiling_face:

Hi Mike,

We’re in the testing stage at the moment. Once I’ve any updates, I’ll let you know.

By the way, one of the users finds a workaround of how to eliminate this issue. You can check this post. I’m not sure whether it works all the time, but you may try it if you want.

Hi Mike,

I’m back with some news for you!

We’ve just released the image that should make your RPi 4 boot correctly now. You need to reflash your SD card with the image from our guide to get this fix. Please let me know how it works.

Hi Liudmila.

I have a problem again. Does not connect to WiFi. I have no Ethernet and Mini HDMI cables, only Wi -fi. I tried as in the instructions, it does not work in any way. Another OS working.

Can you please test it ? Connect to wifi via wpa_supplicant…

I think OS no booting again. Do you test it on RPi 4 rev 1.5 ?

Or problem is a wifi driver or… dhcp service