Image problem

I’ve download the EMLID image for a raspberry pi 4 and navio 2. No matter how I adjust the wpa_supplicant file, I cannot find the device on my network after it boots up. Connecting the board directly to one of my desktop computers via an ethernet cable doesn work either. SSH to either pi@navio.local or pi@raspberrypi.local results in a “could not resolve hostname” error message. IP searches with nmap or the Angry IP Scanner fail to find it as well.

I thought I might be creating the SD image wrong, or that there was something wrong with the raspberry pi board, but then I used one of the standard raspberry pi images and the board booted up and I could connect to it via SSH (to pi@raspberrypi.local) with no issues.
So the board works and the SD card works. That only leaves your image. What can I do to try to figure out what is wrong and fix it?



Looking at the online logs, the most recent update was September of 2020. Does this mean that Emlid is not going to support the Navio 2 boards with any new image updates? If so, that doesn’t bode well for getting this RP4 to work, no? The preceding posts suggest the engineers are working on it, but that was a month ago. I did try to find an older version of the bootloader for the RP4, but couldn’t locate one. :frowning:

Any updates would be greatly appreciated.

I did a separate post on this same topic (accidentally in MISC), then found this. I’ve got the same board and the same problem. I ordered the NAVIO 2 with the understanding it was compatible with the RPI 4. But with the most recent version of the bootloader that is no longer the case?

In the spirit of providing solutions rather than just listing problems:

I finally found a microHDMI adapter so I could see what the problem was when the navio SD image booted up. The boot hung when trying to load the “start4x.elf” file - with the system stating it was incompatible and should be updated. So I took another SD card with the latest release standard raspberry pi image, boot up the board with that, ran updates, then shut it down. Then I copied the start4x.elf file from that SD card onto the EMLID imaged SD card, then tried again.

Worked like a charm - problem solved :smile:

Hi Jeremy,

Thanks for sharing your workaround! I’d not imagine something like this would work, but it’s good you tried it.

Regarding the initial issues with the bootloader, we’ve already found a way to make it work, and it’s now in the testing stage. Once it’s fixed, I’ll let you know.


thanks Jeremy for sharing your solution, although I must say I have tried doing the same thing and it didn’t work.


Hi everyone,

I faced the same problem with 3 Raspberry Pi 4 boards along with the Navio2 board. I tried the solution suggested by @jdslatermd and although the board passed the screen where it states that the start4x.elf is not compatible, then nothing happened and I only saw a blank screen. I let the board running for some time but nothing changed. I also tried connecting via ssh to pi@navio.local but nothing changed. @cristianGPT was this the situation with you as well ? Does anyone have to suggest any other workaround ?

Hi there,

We’ve just released the image with the fix for the issue you faced with RPi 4. Please reflash your SD cards using the image from the following guide.

Don’t hesitate to share how it works for you!

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.