Base fix issues since latest update

I updated both my M2s this morning to the latest firmware. Now I’m having a number of functional issues I don’t think I had before.

My base unit seems to find fewer satellites now compared to the rover even though it’s in a much better location.

Sometimes it finds more but then suddenly drops a large number of them all at once even though they all have a high signal noise ratio.

The RTK updates from the base to the rover are fewer and further apart. As a result the rover often switches from fix to float even though it isn’t moving at all.

Is this a known issue?

It sounds like your correction stream is somehow getting blocked or lost.

How are you transferring corrections? What is your Baud rate? try 19200 or higher for all constellations.

if your corrections are set to one hz, they should be coming in about once a second, if they are not you have a comms issue.

1 Like

That’s what I assumed too. That’s why I was surprised to see such long intervals between corrections.

I am using Emlid’s LoRa radios. As far as I know, there are no baud rate settings for them. It’s highly unlikely that the radios themselves are not working well. This happens even when the two units are only 50 ft apart. And the radios seem to work even when they are a few km apart blocked by heavy forest.

But perhaps they are trying to send too much info, or confusing info, or conflicting info, or something like that. I will focus in on the radio settings and correction data.

The LoRa radio is limited on the number of constellations it can use with 1hz corrections.

1 Like

This fits with what Potatoe Farmer said. The issue is most likely related to communications.

I am going to focus my search around that.

Do you have any idea what the real limits are or perhaps better yet, some recommended settings?

If I remember correctly it will tell you if you get too high. Also, depends on your application. If steering or light at application .5 Hz should suffice

I can’t find a 0.5 option. The lowest is 1.0

I have been able to achieve a solid fix by eliminating constellations. Just using GPS & Glonass at 1 second update rates, I can get a solid lock, but the aging seems to be locked into 7 seconds and therefore, the rover location roves around more than I’d like. Nonetheless, it shows lock now and never drops it.

For reference, my baseline was only 15 meters when I did this test. And, I still only ever get a max of 18 base stations and 37 rover stations as reported by the Rover. However, the base itself says it sees 23.

Both GPS and Glonass constellations are set at 1Hz Update Rate on the rover and base. But oddly, the status screens on both units show strong R & S Constellation signals too even though they are turned off.

Rover correction input is LoRa 902MHz at 9.11 kb/s format RTCM3. Base output is the same.

If the scale of the location map on the status screen is correct, I am getting about 3cm precision instead of 1cm. Good for my needs, but still disappointing.

Sorry, the lower rates are in the Beta version.

1 Like

No problem. I’m not ready for beta anything yet. Heck, I can’t even get the official releases straight yet in my head!

For clarity, I decided to create a new topic for this subset of this issue - “wandering fix”.

My apologies to anyone following this thread.

Hi @Susquatch,

Please make sure you’ve updated your Reach M2 to the Reach Firmware 26. This will help to ensure that your receiver has all the latest improvements within the software.

The age of differential of 7 seconds is a rather big value. It might happen because the radio channel selected for LoRa is occupied for some other purposes as well. Please try changing the LoRa frequency bands to check if it helps.

I’d recommend setting up the frequency at the highest allowed value in your area. If the range is not sufficient for changes of the age of differential, go down with the 1-2 MHz steps until you find the frequency that works best for your area.

I see that you’ve created another thread on this topic. Let’s continue the discussion on it there to keep all the details in one place.

That’s EXACTLY why I made the other thread. I don’t really like creating (or trying to follow) threads that jump all over the place.