Wifi connection via IPhone Personal Hotspot?

Hello All -

I’m have been experimenting with my Reach units and connecting to an available NTRIP correction service. This work well at my house where I connect the reach to my local wifi network.

My next step is to start making the system more mobile so I can go out into fields and still get the correction service. I put my iphone into personal hotspot mode and then configure the reach to connect to it. When I select to connect to MyIPhone network, it disconnects from the home network, but something isn’t working right. The iphone never senses a link. Has anybody been able to make this work? I’m doing everything through the reach view app, so right now I don’t know how to do any lower level troubleshooting on the Reach side.

Also, I’m not sure what I’d use for an IP address to reach the link if I can get it connected to the iphone?


This may help offer some guidance.

iPhone’s hotspot is not found by Reach if it is the 1st device to connect to it, and the Reach switches to it’s own hotspot. If I let something else connect to the iPhone hotspot first, then the Reach is happy to connect to it. Frustrating until you discover this.

1 Like

Thanks…This worked. I connected another device first, then the reach connected. Was able to get correction signals through the phone!

Found the ip address of the reach by trial and error once connected. Is there any utility or way to find the ip address of devices connected to an iPhone?


@feepyj @fraser

Could you please share some more debug info?

Iphone version, IOS version, name of the hotspot, IP address given to the first device and to Reach. Did Reach start its own hotspot or not? Did it connect back to home network?

Could you also try to change the default hotspot password on your Iphone and see if that has any effect? I know this sounds weird, but there were some reports.

If you are uncomfortable with posting it here, you can send it via PM.

Hi Igor,

It will have to wait a few days - got to get all the test equipment set up today, and during test days will be connecting to a different wifi network. (iPhone is also v.old iPhone 4 running iOS 7.1.2… so that might be an edge case in itself!!). Hotspot is “Fraser’s iPhone” and password is 8 alphanumeric chars, all lowercase, nothing odd or strange.

I suspect the connections to the iPhone might be an iPhone thing, and since it is only for testing I’m not too concerned. I record RAW to the reach logs and post process if need be.

The “forming a hotspot in my office” might be some local wifi interference or something, so again, thanks for the advice, but I don’t want to take up your valuable time on this too much - it was more to know if other are finding similar.

The “slow pings and no connection to Reachview after 24hrs” issue is more interesting, given a power cycle cures it. Again could be a network issue. But it’s not impacting my testing, so again… no worries!


1 Like


The phone is running iOs 10.1.1 Hotspot is WorkIPhone (Originally had a space and I tried removing that, no difference). I believe IP’s, were xxx.xxx.xx.8 to the computer and xxx.xxx.xx.12 to the reach. when it didn’t connect, the reach would connect to my home network if it was in range.

What would you suggest for the password. Currently it’s all standard characters in the form of XxxxxxxxXxxxx

If there are some things to test, please let me know

FING is a fantastic tool for this.