Voltage, but no current reading with Emlid Power Module

I installed the power module that came with the Emlid Navio2. Using the latest image from the Emlid website, and ArduCopter 3.4, I configured the settings per the documentation:

I also verified that the LIST of parameters showed:


I get a good voltage reading on the Mission Planner HUD, but the current reading remains at 0.0A even with the motors throttled up.

I must have missed something - what else should I configure?



hi, could you install examples?
and post a screen of the output from
python ADC.py
(ADC | Navio2)

@george.staroselskiy by the way:
the link on the adc for the examples is dead;
it is: Examples setup | Navio2
where it should be: https://docs.emlid.com/navio2/common/dev/navio-repository-cloning/

1 Like

You have to be pulling a few amps to reading anything. And it will fluctuate. And there may be a bug in which amps/volt is off by factor of ten…

Still waiting on a response on that one from emlid.


I also am still not getting amps to display. I even tried a new Emlid power module - same result. I tried your work-around by increasing the amps-per-volt factor by 10, and got some small numbers to show up in the 1-4a range, but they fluctuated as you said. Doesn’t seem right.