Visual Code

I’ve installed Visual Code on Navio2+ RaspberyPi 4.
The installation seems to be OK.
Anyway, running “code-oss” do nothing.
Is there a way to run Visual Code on raspberry pi 4 with navio2 configuration?

thanks,
Eli.

Hi Eli,

Welcome to the community forum!

As far as I understand, you have built Visual Studio Code from the open sources. If it’s so, then VS Code requires a GUI to operate. Navio2’s Raspbian image doesn’t have the GUI by default.

Although it’s possible to install packages to run GUI, it’s not truly reasonable to run it on autopilot. Also, it’s not recommended to install the GUI for an operating drone.

I’d suggest using the default text editor nano or installing vim.

Hi liudmila,
Thanks . well, this is what I am doing.

Now, I try to printf data to console but I see the printing only when I run “sudo systemctl status arducopter”.
Is there a way to open another console to see flunt prints from the ardupilot?

Hi Eli,

The data about arducopter’s status isn’t outputted to the console by default. So it means that you can run either sudo systemctl status arducopter or use journalctl -u arducopter command depending on what data you need. Please run journalctl -h for more details.

Do I understand correctly that you’d like to check the continuously updating status log? I believe you can run journalctl -u arducopter -f to see all the info in real-time.

Also, it’s possible to use tmux that allows accessing multiple sessions in the terminal.

Not exactly…
Actually I just want to see my print output to a console.
I just want to see my
printf(“bla bla…”);
on a console.
Now I don’t see any output.

Hi Eli,

Sorry for the delay.

As far as I understand, you’d like to use one of the built-in commands for text output to the console. You can use printf <format> <arguments> or echo commands, for example.

Thanks for your answer.
Of course I use printf .
But, as I said, the output is seen only when I run “sudo systemctl status arducopter”.
When I run this command, I see few lines of output, and stop.
Whenever I run again the systemctl status command, I see another few lines of output.
My question is simple: why the daemon/program don’t open standard console for output??

Hi Eli,

sudo systemctl status arducopter command doesn’t intend to show the whole updating log of the system status. It was made for a brief check so that you can see whether the autopilot on your vehicle was launched successfully with no errors.

As I have mentioned earlier, you can run journalctl -u arducopter -f that outputs the statuses in real-time and doesn’t stop the thread until you terminate it manually. If it’s not what you were aiming to do, please provide me with some screenshots explaining what you’d like to see. I believe this will help me to get a full picture here.

1 Like

Thanks a lot.

journalctl -u arducopter -f
That is exactly what I needed.

1 Like