V1.2 to 2.1.5 firmware upgrade EPIC fail

i have failed miserably at flashing the firmware upgrade (have tried at least 10 times with the same result). It works fine re-flashing back to v 1.2, but i cannot get the upgrade to work. BTW, I’m using a Windows PC and trying the upgrade via Edison setup interface.
Any help will be greatly appreciated

What error do you get? screenshot
And you followed the edison to the dot, installed driver? Are you using usb 2.0? https://docs.emlid.com/reach/firmware-reflashing/
Using the original reach cabel?

Thanks for the reply TB_RTK. I’m following everything to the T.
This is the image of what i see when i flash v 1.2

Now, this is the image of when i flash 2.1.XXX

I wish I had an answer, but I’m not sure why this is happening…

I’m using the “PISEN” cable that came with the REACH.
I already configured the REACH to connect to a local network broadcasting RTCM3 corrections, however, I want to see more settings and the new interface and i’m unable to since v 1.2 only gives you the 3 tabs and settings buttons…

What happens when you press flash firmware (blue button) ?
I have the same image but everything went fine.

If i hit the blue button it will allow me to grab the image again and reflash. If i go to the folder where the v 1.2 files does the same, but this time it recognizes the firmware on the reach.
I went ahead and did the CMD prompt install…everything looks like went smooth;

then when I got to the Edison tool I got the same message as before that there is no firmware installed on it…it’s kinda frustrating at this point…

Do you get past this screen?
If not and while you are this stage, unplugg any usb device including Reach device, then you try replugg only reach.
If that doesnt work, try another usb port.

If that doesn it, you might wanna try reflashing either with the same firmware or an earlier one. Ex 2.1.3
https://files.emlid.com/images/ReachImage_v2.1_beta.zip

Edit: Keep in mind, its still beta

TB_RTK,
Thanks for all your help! I will trying disconnecting even my mouse when it gets to that screen next… I have tried 2 out of my 4 USB ports already, however I didn’t want to use the USB 2.0 ports, but I might try it and hope I can re-flash the Reach…crossing my fingers…:pray:

Unplugg and replugg reach unit in its usb usually dos the trick. God luck and keep us informed :slight_smile:

I don’t think it’s going to work…two days flashing a firmware? ridiculous…i can’t believe it! Am I the only one that had this problem? Is this an isolated problem? perhaps user error? I just want to think I’m doing something wrong…

Maybe your firmware download was corrupted.

This is what I downloaded on December 5th:
203336646 bytes, Dec 5 2016, ReachImage_v2.1_beta.zip

I cannot guarantee that mine is not corrupt, but this is the checksum of the firmware zip file that I have:
$ md5sum ReachImage_v2.1_beta.zip 0115fb60b00b6be4b74398810e3caa32 ReachImage_v2.1_beta.zip

@jmiranda and others, please post the md5sum of your zip file so that we may compare. Please also include timestamp and filename.

Did you get past this point, or a least to this point?
Sry for all the questions but its not clear what and where it is going wrong.

If not, after you have selected 2.1.5 file and hit flash, does the screen turn black or what?

Do you see this?

bide,
I have downloaded the file at least three different times. I have 2 zip files currently on my machine;

MD5 Checksum: 37D38645D58886C945A1CB7273F3C1ED
December ‎17, ‎2016, ‏‎4:30:42 PM

MD5 Checksum: 0115FB60B00B6BE4B74398810E3CAA32
‎December ‎17, ‎2016, ‏‎6:31:38 PM

Either one of those worked for me.

TB_RTK,

The process goes thru as the v 1.2 did. Exactly the same. Once it goes to the last screen shot u have there it starts connecting disconnecting until the end (computer sound similar then unplugging usb and plugging usb to the machine). Then it goes back and reads the Edison settings and there is where you see that it can detect any firmware (v 2.1.xx)
So as far as I can tell it flashes Edison, but for some odd reason then, the Edison tool doesn’t recognizes the new firmware loaded in.

Ok, so after flashing 2.1.5 fw and rebooting reach, does it create a hotspot or connects to any wifi?

It creates a hotspot and I can connect to it, but the computer or any device cannot reach 192.168.42.1:5000 to do the wifi config or whatever because it is not allowed. Spins and spins until it lets you know that the connection is unsuccesful or something of the sorts . The reach becomes a “brick”. The only connection available is wired (USB) as far as i can tell.
Unless I have to forget the wireless connection already saved on the computer and re- connect to it? is that what I’m missing?
I am assuming since the edison tool cannot read any firmware it didn’t flash properly and try the flash again and again and again…

Reboot reach (unplugg power) and try 192.168.42.1 without the port nr.
Also verify that reach is using this ip adress

After the 45th try rebooting and doing the exact thing over and over I got to flash the Reach!.. Now I’m working on re-flashing my second unit…maybe I will put a video together if I find the time to edit it…special thanks to TB_RTK, without his tips I could’ve never figured out. BTW, this screen below apparently means nothing;

Once you get to this screen, you reboot the reach; then connect to it’s WiFi. Type in your WiFi name and password; then the screen will become unresponsive. Don’t panic (I did like 6 times in a row) Go to your app to get your wireless IP address (I use Fing) type you IP address in your browser and then the reachview will allow you to update to the latest beta version and finish up your installation.
And maybe this was explain somewhere else, but I am not a good reader (I guess)

2 Likes

Pew!, Im glad you got it fixed. I was running out of ideas :blush:

2 Likes

Hello!

Just to be clear on the beta flashing issue. We’ve stripped a lot of Intel’s stuff from the image to make room for logs and our software. The new beta will not work perfectly with Intel’s flasher, but you should be able to flash it.

We have a flasher of our own in the works to clear this mess.

Big thanks to @TB_RTK for helping out!

1 Like

Hello,
I have been having similar issues - the two Reach units I have will not update to v2.3 Both will flash fine to v1.2, but will not do the update to v2.3 I get to the point that jmiranda shows in the screen shot above. I can connect to it’s WIFI. I then get the Updater screen and enter my WIFI information. With v2.3 loaded, it says it is connecting but never shows up using Fing (or when I look at my router - with v1.2 the reach unit shows up and I can connect to it on my WIFI). I have tried doing the command line flash running from the uncompressed directory where flashall is located and get the following:

Using U-boot target: edison-blankrndis
Now waiting for dfu device 8087:0a99
Please plug and reboot the board
’dfu-util’ is not recognized as an internal or external command, operable program or batch file.

Any thoughts???