Using mobile phone for Internet and for ReachView at the same time


(Zoran Nedeljkovic) #1

Hello,
It is not clear how to establish connection with Internet and with application, at the same time (with one mobile phone at the field).
It seems that I need two phones at the field to work with NTRIP corrections: one to provide Internet, and second for the application.

Sorry if I asking question which is maybe solved earlier… There are so many topics…

Regards,


(Christian Grüner) #3

Nop, just 1 phone required.
Share your internet-connection on your mobile and have your Reach unit connect to it. Et voila!


(Timd1971) #4

You’ll create a HOTSPOT using your cell-phone and with your cell-phone provider service. Depending on your region, some cell providers offer sharing the internet as a HOTSPOT, some do not, and some charge additional in order to do so.


(Gleb Gira) #5

Hi @cobatz,

You can use one phone for sharing the Internet and getting access to the Internet.

For this, proceed to the “Wi-Fi” tab of the ReachView app and press “Connect to a hidden network”. There you’ll need to enter your hotspot credentials and turn off the device. Start sharing the Internet on your phone and turn on Reach. After booting on, Reach should connect to your hotspot, and you’ll be able to connect to it via a phone app.

Please, follow this guide, if you still have questions.


(Christian Grüner) #7

Or, if you have an RS2 with an active sim-card installed, you can simply connect to the RS2 and choose the option to share the internet on the RS2, simple and effective! :smiley:


(Jared Dickinson) #8

Do you have any recommendations for a service provider or what I should be looking for / avoiding? I’m considering a SIM card for one of our RS2 receivers, but this is a bit foreign to me. The reach RS2 uses a nanoSIM card and my work cell phone uses a microSIM card so I wasn’t able to test it out. Should I be concerned about compatibility?

Thanks!


(Jared Dickinson) #9

Hi @gleb.gira,

I ran into this same issue with our new RS2 as well and I believe that I followed the guideline exactly. I could get the unit to connect to the mobile hotspot without issue, but I could not connect to ReachView v2.20.x after it was connected to my mobile hotspot. I confirmed the hotspot was working by connecting my laptop to it. In the mobile app, it will not find the receiver. I am using a Samsung Galaxy S8 with AT&T as a provider.

Do you have any other recommendations or knowledge of issues with certain phones or service providers?

Has anyone had success with this using the v2.20.x with an RS2?

Thanks!


(David Hofer) #10

Works awesome


(Jared Dickinson) #11

@davehofer1993

Good, so that eliminates the software being an issue . Would you be open to sharing what you use for a phone and service provider? It may come down to the only variable being the user :smile:


(Timd1971) #12

Ha! When it comes to mobile service providers, just pick your poison, they all suck! (Just like cable, internet, insurance providers) ; )

I use Verizon, but had AT&T before hoping Verizon was better as it’s hyped so much as being better, but from experience is no better and even worse. Will change back to AT&T more than likely. Central USA.


(Jared Dickinson) #13

@davehofer1993 I should have been more specific in my question. I am wondering if anyone has had success using the RS2 and ReachView v2.20.x through a device (i.e. tablet/phone) that is both providing the mobile hotspot and accessing the receiver through the app. Hoping your answer is still yes :crossed_fingers:


(David Hofer) #14

I miss read that I mostly only use LORA and works good for me . Sorry


#15

Had some issues with earlier version (prior to 2.20.1) when i had the sim installed.
But havent tested with the 2.20.4 yet

I my region 3G is really poor so i need to use the 2G which is excellent. Make sure you pick a provider with best coverage.
Oh and 2G with RTCM at 1hZ ntrip works just fine. Speed was not an issue during my tests in 2G only area.


(Christian Grüner) #16

Sadly I am not of much help, as the choice of provider is a local one.


(Dmitriy Ershov) #17

Hi Jared,

Could you describe at what step you have issues exactly?

Does LED on Reach RS2 indicates it is connected to a Wi-Fi network?

Do you see Reach RS2 in the list of devices in ReachView app?


(Jurijs Ješkins) #18

I am constantly connecting my RS2 to the phone via mobile hotspot. I am using only one phone, which is a mobile hotspot and a controller. Haven’t had any issues. I know, that some of the smartphones still has the bug, where Reachview can’t see the unit, but you can open the Reachview via browser (by using RS2 ip address). A colleague of mine has Blackview BV6500Pro and he had this issue previously (I think it was with v. 2.20.2).

Maybe you try to open Reachview via browser? Do you see in your Samsung, that you have actually a device connected to your hotspot?


(Zoran Nedeljkovic) #19

I have Reach RS+…
Tell me, please which phone is work fine?

I’ve tried everithing without succes.
Maybe the problem is with my phone, Motorola E4 Plus…

But… I need to tel you: such trivial thing, like connection of receiver and control software, does not deserves time for discussion.
Integrators need to resolve this issue with more robustness.
Thank you for your good intentions.

Kind regards,


(Dmitriy Ershov) #20

Could you tell please at which step of this guide you have issues?

https://docs.emlid.com/reachrs/common/tutorials/connecting-to-the-internet/


(Zoran Nedeljkovic) #21

I’ve do this steps:

Connecting to ReachView¶

  1. Connecting to Reach with iOS/Android device
  2. Get the app from Google Play or Apple Store
  3. Go to Wi-Fi settings on your device
  4. Connect to Reach hotspot. It appears as reach:XX:XX
  5. Enter password emlidreach
  6. Launch ReachView app
  7. Choose Reach from the list

  1. Go to the Wi-Fi tab
  2. Choose Wi-Fi network
  3. Connect to a hidden network

Steps for mobile hotspot

If you connecting to mobile hotspot do the following steps:

  1. Enable Wi-Fi hotspot on your mobile device
  2. Check that it has the same name and password as you filled in the previous step
  3. Now reboot the device with the Power button
  4. Reach should connect to your hotspot during the next boot
  5. If the connection is successful, you will see blue LED is blinking slowly (THIS BLINKING IS OK…)

Go back to ReachView¶
Connecting to Reach with iOS/Android device

Connect your mobile device to the same Wi-Fi network as Reach (THIS IS THE PROBLEM: How to receive Internet signal by wifi, in the phone from itself? My phone hasn’t such possibility. Every time when I start WiFi to receive Internet, HOTSPOT shutting down, and vice-versa…)

Scan for available Reach devices

Choose Reach from the list in the app (THERE ARE NO ANY RECEIVER IN THE LIST, FOR HUNDREDS OF SCANNING…)


(Dmitriy Ershov) #22

Ah, I see.

There’s no need in enabling Wi-Fi on your mobile device if you use it as hotspot with Reach.

Once Reach’s blue LED is blinking slowly, go to ReachView app on your mobile device and search for the devices. You should see Reach in the list.

In case you don’t see Reach in the list, then it must be something with device’s scanner on your Motorola E4 Plus. Unfortunately, this sometimes happen to some Android devices, there’s not much we can do here.
You can use Fing app to determine the Reach IP address and go to ReachView via a web browser.