Using 3DR radio for Base-Rover communication

Hi guys, I’m trying to use 3DR radio (v1.3) in order to connect two Emlid and transmit the BASE data through radio channel to the ROVER.
In general I have this situation: I’m on a roof where I’ve no WiFi so I’m setting up BASE and ROVER via Reach App where I have WiFi, play “Start” (waiting for the green lights) then I go up to the roof and I leave the two Emild acquiring.
At now I don’t achieve fixed solutions so probably I’m making something wrong.
In your experience, is it correct to set the following parameters?


Thank you very much for your help!



Could you be more specific on how you connect the radios? These radios come in pairs - one with UART and one with USB connector. Did you connect one of these through an OTG cable?

My recommendation would be to update ReachView to the newest version, which, among other things, makes the process of connecting serial devices a little bit easier

Hi Egor,

actually I think you centered the problem: I’ve found two 3D radio and I was trying to use them but I’ve got no knowledge about communication so… I used UART connection for both and probably this is very wrong :anguished:

So, from your comment I understand that I have to connect one Emlid (base) through OTG cable (and supply power via DF13 port) to the radio and the other Emlid (Rover) via UART.

This is also can be argued from the new ReachView. :tada:

Hence, which “Device” do I have to specify when I set up the Base?

And which boud rate?

I’m sorry if this discussion is under a certain level but I hope that this will help other enthusiastic beginners in this field :four_leaf_clover:

Thank you very much for your help and your work!


Yeah, you should connect one UART radio via the DF13 connector and one through USB. With the latest ReachView you can just choose the right device(with the USB - connect it first) and use default baud rate(57600 for those radios)

It doesn’t really matter which radio you connect to which Reach, just setting the correct type in the settings is important.

If you have several pairs of these radios, try to set the modules and check rover’s satellites via the app. If there are grey bars showing base levels, you have the link. If there are none, you should swap the radio. Unplugging USB radio without stopping base/rover will disrupt the process, so you should only swap the UART one or stop processing before swapping

You shouldn’t be sorry, we are still working on the docs, they are being updated regularly and correction link guide will be added too.

One more thing, if the USB radio will not show up in the list, you should perform the update again, even though it will not bump the version of the app.


I have some similar problems with the APM 3DR radio and was set
up the REACH kit with the following configurations:


Output path for corrections: serial, UART, 57600

Output format: rtcm3

RTCM3 Messages for Output: 1002, 1006, 1008, 1010, 1019,

RINEX version: 3.02

ReachView version: v0.1.0


Positioning mode: kinematic

Used positioning systems: gps, glo

Input source for base corrections: serial, USB

Input format for base corrections: rtcm3

RINEX version: 3.02

ReachView version: v0.1.0

3DR RADIOür-apm-pixhawk-p237907.htm


When I configure the BASE and the ROVER similar to the Quickstart
Guide over tcpsvr, then I get the corrections data into the ROVER (I see the grey
bars over the app). Everything works fine. As soon as I switch to the UART USB mode,
the corrections data are no longer available on the ROVER.

I checked further the 3DR radio link with my Laptop and the
Software BKG Ntrip Client. I saw, that the corrections data stream from the
BASE is correct. Therefore, it seems that the problem is between the 3DR radio
USB modem and the REACH. Do I have to preconfigure this USB 3DR radio before I plug
it to the REACH or do you have some other ideas what could be wrong?

Thank you for your help.


Hi guys,

I made the connections as suggested by Egor:


But still there is no transmission.
On ReachView I set:


Output path for corrections:

RTCM3 messages for output 1002


Input source for base corrections
UART (sorry Andrew, how did you set here USB? I see only UART option…)

Input format for base corrections

Solution output path

Raw data log for onboard receiver

Raw data log for base corrections

Thank you in advance for your help and suggestions!


Hi Elisa,

Since both your radios are UART type, could you please try connecting both units identically over UART?

USB option appears only if a USB device has been detected.

Hi Igor,

yes now the communication works…float/fix!! :tada:
I connected both units identically over UART as you suggested, thank you!

I add also a picture if it could be useful for other users (it was not very obvious for me to understand how to connect the different coloured cables :flushed:)




Hi Igor,

How can I check, if the USB Baud rate of the Reach is proper?
I have now integrated the 3DR radio on the USB port of both REACH modules and forwarded
the BASE raw data to the UART of the ROVER. The idea is to check, if the corrections
data are correct received on the ROVER side. It seems, that the data stream
from the BASE station have not been processed correctly. Maybe a problem with
the USB Baud rate or the ROVER configuration?

I checked the 3DR radio link already with my Laptop and the Software
BKG Ntrip Client. The corrections data from the BASE seem to be properly.

BASE config:

Output path for corrections: serial, USB

Output format: rtcm3

RTCM3 Messages for Output: 1002, 1006, 1008, 1010, 1019,

RINEX version: 3.02

ReachView version: v0.1.0

ROVER config

Positioning mode: kinematic

Used positioning systems: gps, glo

Input source for base corrections: serial, USB

Input format for base corrections: rtcm3

RINEX version: 3.02

ReachView version: v0.1.0

Thank you for your help.


Can you see grey sat bars on rover device?

Baud rates do not apply to the USB inteface, you should not worry about that

Hi Egor,

No, unfortunately not. I tried different setups:

  1. corrections data over Wi-Fi => everything works fin,
    RTK fix and grey sat bars on rover device.

  2. corrections data over USB and 3DR radio => no grey sat
    bars on rover device.

  3. corrections data over UART and 3DR radio => no grey
    sat bars on rover device.

The funny thing is; the chain BASE - 3DR radio - 3DR radio –
LAPTOP seems to work. So the radio link should be configured properly.

got the same, anyway will work on wifi to try to have an corrected mnea outpout on serial port to feed a pixhawk…

hope the integration on pixhawk will be released soon

I had the same problem: My base sends with 115200Baud via USB OTG, so I had to change the Baudrate of both 3DR radios and the Rover to the higher Baud-rate, no clue, why this was changed.

so with the 3dr set to 115200 it suppose to work ?, just use 57600 for now.

working with wifi mode eccept for the serial mnea output , only bluetooh work… even If I refresh my cash


I just pushed v0.3.1 update yesterday. It allows setting baud rate for USB devices. Should be ok to use any radio configuration now.

Good news will make some test on Monday morning

ok , it’s possible to have the rtk solution with 2 3dr modem working since usb and uart baudrate are selectable.

I see the grey bar and the color bar lik in the wifi setup.

sound good , but…

still inpossible to obtain serial Mnea on the seria output df13 of the reach or in the modem. output

I use 2 usb modem actualy

it’s not working if I use one usb and 1 serial …

the bluetooth has not been tested anymore since it’s not possible to connect on my laptop or my note4 samsung , since I have no more time to put on this…
need to feed the gps port of the pixhawk with mnea corrected

Let’s try the Drotek board right now ,…

If you are looking for the Pixhawk integration, it is in the docs:

It is really hard to tell what you are trying to achieve. If you could explain the desired configuration and what is not working we will help you.

just try to have one base with a usb 3dr modem connected on it at 57600 bauds working no wifi cause I don’ plane to use a router on the field.

rover : one 3dr in USB or Serial to receive the information of the base.

the output of the rover is to feed the gps port of the pixhawk or of implemented the serial 4/5.

so the base and the rover good comunicate.

now, I want just a serial mnea output of the serial port of the reach to fed a gps input , pixhawk or simply the hyperterminal on my laptop via fdti or anotehr couple of 3dr radio with another ID.

the stream output is always c3 on the hyperterminal of my pc… but with blutooth and wifi we are able to have the mnea output…

so the serial output 2 of the reach donT seem to works but the serial on the bluetooth seem to work…

what’s going wrong there.
Going to read the new documentation you finaly release…

next step is the drotek board ready on my desktop

ok just pass away something

The setup we recommend goes as follows:

Base stations is a Reach unit in Wi-Fi AP mode, configured as a TCP server
GCS is a laptop with Mission Planner(version 1.3.35 and higher), connected to the base Reach Wi-Fi hosted network
Telemetry connection via a serial radio
Rover Reach unit is mounted on a drone and connected to Pixhawk via the 6P-to-6P wire. This connection type will solve three problems at once: power Reach, allow Pixhawk to pass base corrections and allow Reach to pass RTK solution back.
The following guide will show how to configure both Pixhawk and Reach to work in this setup. If you wish alter to this workflow, it should be fairly easy to do so, as every part of the system is independent of others.

just one question about the compas… it need the original gps antenna of the pixhawk to to acces compas ? or the reach imu working now ?

I made some test know kep you informed