Used satellites count in RTKPost pos solution very low


Whenever I postprocess 2 datasets (rover+base) from the Reach RS+ will all systems (except beidu) enabled, I always end up with 5-10 satellites used, when I inspect the .pos file.
Given that I usually have 23-25 sats in view , I wonder why it is only using 5-10 for the solution?

I have tried completely disabling SNR/Elevation masks, but doesn’t make a difference.
I have also tried with default settings, no AR modes etc, still the same count. Why is that?

Using RTKlib 2.4.3 Emlid B28

What’s your typical elevation mask? The lower you drop it the more satellites you’ll get but that doesn’t necessarily mean that is going to use them.

As mentioned, elevationmask and snr mask doesn’t change it much. Tried everything from 0-20 deg, and also disabling the snr mask all together. Question is, what then dictactes what sats being used?

Why don’t you run the processing with GPS only and see if you get the same number of reported sats? That might tell you something. Then run with just GPS and GLO and compare again. To be clear, I’m talking about enabling/disabling satellite systems / not about messing with your ambiguity resolution settings.

Good point! I’ll try that.
I did try something similar, using only YYn or YYg nav files. Here it seems that if you only use the GPS nav, I only GPS Sara will be used, and vice versa.

Ok, so the plot (no pun intended!) thickens!
Using 2 RS+ datasets (so only using obs, nav and sbs from these), with all relevant (GPS, GLO, GAL, QZSS, SBAS) systems enabled, I get Q=0 with all except the GPS system.
When I process using the GPS and then process with all systems selected, the resulting .pos is exactly the same for the 2 runs.
Looking at the obs and nav files, I can see non-GPS systems in there, so the non-GPS data is available in the files.

What the beep is going on ? Can someone reproduce this ? This happens on 2 separate computers as well.

I think “solved” it. When using “Broadcast + SBAS” or “Precise” (using GPS), it will limit used systems to GPS only. So it’s basically down to combinations of settings.

So here’s another question: Where do I find Orbits & Clocks from more than just GPS & GLO ? Nothing for Gallileo somewhere?


And to answer my own question ince again (hopefully to benefit of others), then I contacted NASA’s CDDIS, who responded within minutes with

I am having a particularly difficult stop & go session with lots of buildings and foilage, and the extra systems did indeed give me more fixed points. Now just looking forward for the final solution, not just the rapid.


Hi @wizprod,

Glad to hear you’ve found the source of the problem. Thanks for sharing the solution.

That’s what a forum is for, in my mind :smiley:


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.