Low amount of satellites (ns) after RTKPOST with CORS as base

Hello. I am trying to get consistent result with PPK, but unfortunately I get .pos file with small amount of satellites (ns value in .pos file) - I get fix or float only with 6-7-8 satellites. Moreover, sometimes if it is fixed - results are inconsistent. I assume that only data from GPS sattelites are processed, while .obs file from rover and .o file from CORS include GPS, GLONASS, GALILEO and QZSS data. So I can receive strong signal from at least 12-15 satellites at any time. I have tried bunch of different versions of RTKLIB - from Emlid, original 2.4.2 version, newer version from Github(2.4.3 b30). While 2.4.2 and 2.4.3 b30 fails to give me proper .obs file (I get .obs file only with GPS data), Emlid version at least gives me proper .obs file. But then I struggle with RTKPOST. It just so random - I once had proper .pos file with around 15 satellites (ns) with old 2.4.2 version, then I have tried repeat it with Emlid version of RTKLIB - got only 7-8 satellites. After i tried to play back with old 2.4.2 - nope, again only 7-8 satellites and inconsistent result.

I have uploaded to Google Drive .obs from rover, files from CORS (got it from Geospatial Information Authority of Japan) and config file for RTKPOST, which I use. I will appreciate any help.

UPD. I have found topic with similar problem on this forum, but seems like that solution does not help me - I do not use “Broadcast + SBAS” or “Precise” in settings.

What is your SNR and angle limits set to?

Do you mean elevation mask? Elevation mask is 15 degree and SNR - 25 dBHz for both rover and base.

Can you post your settings from RTKpost? Just as a few screenshots.

I have experimented a little bit since last reply. Here some screenshots of settings, which I use at the moment:


Most significant change probably - switched Ambiguity Res for GLONASS from “on” to “fix-and-hold”. Thanks to article of rtklibexplorer - i can not leave it “on”, because CORS and reach are different type of receivers. Anyway, I still get 6-7-8 satellites. I have tried to switch it to “off”, but nothing changed, so I will leave it “fix-hold” for a while, as rtklibexplorer recommends.

Hi @mkungaa,

Can I ask you to share your raw rover UBX log and raw base log, please?

Here is a thing - I do not have raw logs from base, because survey was made in RTK mode for UAV SfM purposes. But .csv files from RTK survey are kinda broken, so RTK results useless for georeferencing in Agisoft. So i tried to use raw logs from rover. Thanks god I have turned on logging at least on rover, but I forgot to turn on it on base. So instead of base’s logs I am trying to use CORS logs from Geospatial Information Authority of Japan. Somehow I have screwed up with georeferencing, so I am desperately trying to fix it.

I have uploaded .ubx file from rover to Google drive, but I can’t upload .ubx from base, because I do not have any. ¯_(ツ)_/¯

Hi @mkungaa,

I’ve processed your logs.
Here’s your track. You can see that there’s a fix solution most of the time.

However, you’ve got a lot of satellites but satellite view is poor with a lot of cycle slips.
What hardware setup do you have? What’re environmental conditions?

1 Like

What about amount of satellites used for PPK (ns parameter)? Could you upload .obs and RTKPOST’s config file to somewhere? I want to compare with mine. I get much less fix result and more float. I will really appreciate it.

We have used Emlid Reach with antenna mounted on 10x10 cm stainless steel plate connected to survey monopod. The thing is that it was RTK survey, and never intended for PPK. We were keeping rover on point just enough time for RTK fix. But somehow RTK results are terrible and not usable for UAV SfM.

Hi @mkungaa,

As you can see in the screenshot, I’ve quite a lot of satellites (usually 20 and more).
I’ll send you .obs and .config file in DM.

Can you show me your hardware setup and environmental conditions photo?

Sorry, I have misleaded you. I am talking about ns parameter(as I understand - it is amount satellites used to get FIX) in .pos file. Can I see your .pos file too? I usually get normal .obs with a lot more than 20 satellites, but problem wit .pos.

I will DM to you, when I get to university. Unfortunately, it won’t happen until next week.

I have used .obs and .conf file send by you and processed by RTKPOST. This is what I get:

As you can see - more float results than yours. I use RTKPOST ver.2.4.3 Emlid b28. And this is ns value from .pos, which I get:

As you can see 6 (max 8) satellites participating in process of getting FIX. It is not clear why such a difference between your and mine results occurs. Is there any chance that hardware affects results? I have no other clue…

@mkungaa, can you show me your step-by-step actions with screenshots?

Open RTKPOST, press “Options…”:
Press “Load…”, choose .config file, that you have sent me, press “Открыть”

Press “OK” button:
Press first “…” button next to RINEX OBS: Rover, choose .obs file, that you have sent me, press Открыть

Press second “…” button next to RINEX OBS: Base station, choose .o file from CORS, press Открыть

Press third “…” button, choose .n file from CORS, press Открыть

Press “Execute”, press “Overwrite”:
Wait until it gets “done”, then check results pressing either “Plot…” or “View…”(to check ns-value).

@mkungaa, you need to use rover .nav file during processing.

Let me know about the result.

1 Like

Oh God, thank you very much. Finally normal results. Huh, never expected that I should not use .nav file of CORS station.

1 Like

Can you explain why that is ? Wouldn’t the nav file of the cors usually be of higher quality?

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.