URGENT - RS2 won't boot or flash

Today I noticed a firmware update so thought I’d get it done. I did it over the hotspot to my phone. Everything downloaded OK but when it got to the installation it failed and now the unit won’t start. It just flashes across from left to right (as if trying to start).

I’ve downloaded the Firmware Flash Tool on my mac but it fails each time and I’ve now tried it on a different mac but no luck there either. Looking at the logs it shows up as:

‘flash_controller.py - INFO - Job error: Can’t find storage device’

Also tried to install the Firmware Flash Tool on a PC. The program installs but won’t open at all. I can see the process is running in the background but can’t see it on screen.

I need to use it on Thursday on site - panicking now!

I sent the logs and this topic in an email to support@emlid.com yesterday but thought I should post here for the benefit of others.

1 Like

Hi Andy!

I received your message.

Do you have another USB-C cable to try?

Some antivirus software can block Firmware Flash Tool. Please, check that security settings allow using Flash Tool on your PC.

I need to ask you for some sensitive information, so let’s continue our conversation in email.

1 Like

Short update.

Andy informed that the flashing on another PC helped to restore the unit back to normal!


A post was merged into an existing topic: A new RS2 worked fine but now wont turn on