Upload GCPs into Pix4DMapper

I created GCPs in Emlid Flow using my RS2+ Rover/Base. The format was Global Coordinate System in Emlid Flow as a CSV file. I tried to upload the CSV file into Pix4DMapper with no success. The format Pix4DMapper had was WGS 1984. Can anyone help me with this.

Hi @chrisrward.acct,

Welcome to the community!

What error message do you see when you import the CSV file from Emlid Flow? I’m not sure if this guide from PIX4Dmatic will work for PIX4Dmapper, but it’s worth trying.

The CSV file should contain the name, latitude, longitude, and height columns. Please try exporting a custom CSV in Emlid Flow and choose only the required columns.

1 Like

Hi! I initially got an error that the format was wrong. I was told to remove everything from the file except: Name, Lat, Long, Altitude

I did this and got an error the one of the points is way outside the area that I am working in. This made me think the Lat, Long, Altitude is in different units or is there a difference between Altitude and Elipsoid height?

Thank you for your help.

Hi @chrisrward.acct,

I believe it has something to do with the horizontal coordinates. Based on your description, the GCPs appear to be outside the survey area.

To clarify, you set the project CRS to geographic WGS84, and the coordinates in the CSV are in latitude-longitude format and not easting-northing, correct?

Can you share the CSV file here so I can check? Also, the screenshot of the project settings in PIX4Dmapper would help. Thank you!

Hi Ruth. I think I see something when I look at the data. When I choose WGS 84 the x and y output is in degrees. The software that I am trying to upload the points is looking for meters. Is there a way to get the x and y in meters for some type of work around?

Sorry I’m just getting back to you. I was out in the field. I have tried everything. I tried to upload the file but it will not let me upload a CSV file. I will try and copy and paste the first point.

Name Code Easting Northing Elevation Description Longitude Latitude Ellipsoidal height Origin Easting RMS Northing RMS Elevation RMS Lateral RMS Antenna height Antenna height units Solution status Averaging start Averaging end Samples PDOP GDOP Base easting Base northing Base elevation Base longitude Base latitude Base ellipsoidal height Baseline Mount point CS name GPS Satellites GLONASS Satellites Galileo Satellites BeiDou Satellites QZSS Satellites
1 490508.557 3761323.745 58.844 front right -81.10277016 33.99245123 58.844 Global 0.01 0.01 0.01 0.014 2.134 m FIX 2024-05-01 13:46:06.4 UTC-04:00 2024-05-01 13:46:06.4 UTC-04:00 1 1.1 1.2 490457.326 3761297.531 60.967 -81.10332459 33.99221435 60.967 57.572 WGS 84 / UTM zone 17N 10 8 6 6 0

Pix4DMapper only wants 4 columns. Name, X(m), Y(m), Z(m)

Thanks for trying to help!

Hi @chrisrward.acct,

How’s it going? Were you finally able to import the CSV file from Flow?

I cant upload a CSV file.

Hi Ruth,

I started over to see if I made a mistake. I did a project where I created 11 points in coordinate system NAD27 / South Carolina North. I took the export file and created the load file for DroneDeploy software that I have. They only needed North, East and Elevation in (ft). I will attach both to this message if I can. When I it gives me a preliminary look before the final upload it looks like the distribution of points is correct but the pattern is shifted compared to the map I’m using. I cant tell if the points are not in a valid place or the map is in the incorrect place if that makes sense. If I look at the points in Long, Lat that’s in the file and put it into google earth they appear correct. I don’t know if I’m doing something wrong with the where the base is or rover but the points are not where I expect on the map. Hope this makes sense. Thank you for the help.

Hi Chris

If you are using our states RTN, they are broadcasting
ITRF 2014 (WGS84, approximate for your software).

When I’m flying a site I use the state’s RTN and collect any GCP in the same datum as above. I then bring everything into Metashape and process. When completed, I simply export to SC NAD83(2011) Geoid18.

The data fits to the NGS’s data !

2 Likes

Hi @chrisrward.acct,

@EBE111057 is right. It could be a datum mismatch. How did you collect your GCPs with Reach? Do you have another device acting as the base? Or is the Reach rover receiving corrections from an NTRIP service? If so, to which service was it connected?

In the GCP manager, make sure you specify the correct input CRS at the top so it matches what you captured with the Emlids, but also that the coordinates order is correct (when you click on import GCPs) so it matches what’s in your file. It can be X,Y,Z (lon,lat,elev) or Y,X,Z (lat,lon,elev) and if you choose the wrong one, it will give you the “points are outside of area” error.

1 Like

Hey Gabriel, What are you referring to as GCP manager? I’m using Emlid Flow. Is that what you mean? When you say CRS do you mean the coordinate system? Sorry for my ignorance. You were dead on regarding the x,y,z and y,x,z. I made sure I got those in the correct format. Thank you for the help on that.

Hey Ruth, Yes, I think the whole thing is a datum mismatch. I also had to make sure I was using the same units of measure (ft) vs (m) for the Northing and Easting. It still didn’t look pretty when loaded and 3 of my 10 GCPs were pretty spot on. I use Reach RS2+ for both Base and Receiver. I have to say, I love using this equipment. It’s so intuitive and all the software is so helpful. I just think there are issues between the datums even if you match the format in Emlid. Next time I’m going to see if I can capture my drone footage in WGS 84 and see if I can use that through the whole process.

Hey Bryan,

Let me say first to everyone. First, thank you everyone for the support. Secondely. I was able to get the file to load. It appears that when you load the file into DroneDeploy’s GCP upload process it looks really off target from, for lack of a better way of saying it.

I made sure captured the GCPs on the coordinate system NAD27 / South Carolina North. I also made sure I loaded it the same way. I still had to manipulate the upload file because it only wants East, North and Elevation. It also wanted Northing first so I had to move that. The processing software only figured out where 3 of my 10 GCPs were, even well marked. I was very disappointed with that. I really don’t have any love for the way DroneDeploy or Pix4DMapper handles GCPs. I’m sure it’s me, but the workflow I used was painful. I’ll say more in the other responses people gave me. If you can continue to give me some wisdom, I would love it.

BTW - You lost me on “state’s RTN”. I’m sure I need to learn more.

HI @chrisrward.acct,

I’m curious why you need to use NAD27-based datum for your project. Does it need to line up with the old maps? I am not sure what the situation is in the US, but is NAD27 still used in everyday surveying workflow?

Also, could you please explain your data collection workflow to us? How do you collect the GCPs? Is the base setup over the known point?

Further, how are the drone images collected? Are you using an RTK drone, and does it have a real-time link with the base during the survey?

Thank you!

1 Like

In Pix4DMapper, the interface to load GCPs from what you would output in EmlidStudio. Are you now working through DroneDeploy? I don’t know that platform so I can’t really help on that.

Hey @ruth.bongon That is a very good question. Hopefully your response to my answer will help me tremendously. I hope what I’m about to write makes a some sense.

To answer your question: I started DroneDeploy (DD) and mapped out the mission I was going to fly in their software. It pops up with a recommended coordinate system (CS), which was NAD 27, to use based on the location of mapping. I didn’t use the DD flight mapping software, but I did take into consideration the recommended CS to use when I exported my GCPs in Emlid Flow and also when I did the actual flight plan for my DJI fly app for a Matrice 350 RTK and Smart Controller with the DJI Mobil Station. I place the DJI Mobile Station on the same spot that the Emlid Base was on just in case it helps with accuracy.

Colleting GCPs - I use RS2+ for Base and Rover. I do not have a Known Control Point (KCP), but I do collect about 1.5 hours of data from the BASE in the hopes of using U.S. OPUS one day. In OPUS I also specifically look for the same CS. By the way I haven’t used the OPUS to create a KCP because I can’t see where I can get the elevation in what it sends you back for a good KCP. Long story short, I do not have a KCP as much as I want one. I was hoping I could eventually get the data back from OPUS one day and manually put that into DD for at least some idea of a KCP.

I know this is a lot of information, but I really hope it helps. In summary:

  1. I use NAD 27 because the software recommended it. I would rather use something better.
  2. I don’t have a KCP. I use a RS2+ Base and Rover. I wish I had a KCP, but I am unable to get one that from a surveyor most times.
  3. I fly the mission with a DJI Matrice 350 RTK and DJI Mobile Station.
  4. I put everything in DD for processing.

I’m excited to hear everyone’s responses!

Chris

Hi @chrisrward.acct,

Apologies for the delay. OPUS is a good idea for establishing a known point. With OPUS, you can have NAD83(2011) coordinates and ITRF2014 coordinates.

The best choice is to use NAD83(2011) coordinates for your base. Will you be flying to the same site several times? If yes, you only need to establish the known point once and use this same point as KP for your subsequent surveys.

If you have the CSV with the raw data logs from both receivers, please feel free to share it with us at support@emlid.com, and I’ll help you post-process your data to help you get started. :slight_smile: