Updating above ArduRover 3.4 on Navio2

I have a Navio2 and I’m experiencing the wide turns on my rover. I read that’s a known issue with ArduRover 3.4 which is what is currently running. I can’t seem to figure out how to update to a newer version. I followed the steps here https://docs.emlid.com/navio2/common/ardupilot/upgrade/ and my pi is up to date. I didn’t get a screen that this link shows about updating ardupilot but all is up to date according to apt-get. Anyone know how to update ArduRover to a later stable version?

You must have some basic Linux knowledge before performing the operation.

You connect via SSH to your navio

YourComputer:~ yourusernane$ ssh pi@navio.local

enter password

##point to where is your ardurover file

cd /opt/ardupilot/navio2/ardurover-3.4/bin

##List the files in the folder
ls -l

##rename and overwrite the old file

sudo mv -f ardurover ardurover342

##download the latest stable version

sudo wget http://firmware.ardupilot.org/Rover/stable-3.5.1/navio2/ardurover

##change it as executable

sudo chmod +x ardurover

##reboot

sudo reboot

Thank you. I followed the steps but it still appears to be running 3.4. At least according to Emlidtool. used systemctl show -p FragmentPath ardurover.service to find the location of the script file and opened it (nano /etc/systemd/system/ardurover.service). It’s running ExecStart=/bin/sh -c "/usr/bin/ardurover ${ARDUPILOT_OPTS}"

I took a look at that file and it appears to be a symbolic link to another file.

after looking at the other file, that appears to be another symbolic link pointing back to the file you directed me to update.

So, at the point, i’m thinking that the update succeeded but Emlidtool is reporting the wrong version. Do you know if it should be showing 3.4 or 3.5.1?

Hello,

The update rover method is a quick one. I just change the ardurover file. So Emlidtool is still looking in the 3.4 folder.

When you open the mission planner to configure your rover, it say 3.5.1 is running.

I created another directory here
cd /opt/ardupilot/navio2/ardurover-3.5.1/bin
and ran
sudo wget http://firmware.ardupilot.org/Rover/stable-3.5.1/navio2/ardurover
and set the permissions using
sudo chmod +x ardurover

I also redirected the symbolic link
\etc\alternatives\ardurover using sudo ln -nvfs /opt/ardupilot/navio2/ardurover-3.5.1/bin/ardurover /ardurover

After loading Emlidtool it now shows both options. I haven’t tested it but i’m guessing the symbolic link \etc\alternatives\ardurover is programmatically once I select it in Emlidtool. Anyway, I think i have what i need now and hopefully documented enough for someone else if they want to do this. Thanks for the help.