Update / Upgrade Raspian Navio2

Is there any possibility for “sudo apt-get update && apt-get upgrade” with the newest raspian release of NAVIO2? Only get error messages when doing this command ("…not valid yet…will not be applied…")
Thx!

Syntax is

sudo apt-get update && sudo apt-get dist-upgrade

with same error:

pi@navio:~ $ sudo apt-get update && sudo apt-get dist-upgrade
Get:1 http://archive.raspberrypi.org/debian buster InRelease [32.6 kB]
Get:2 http://files.emlid.com/navio2/debian buster InRelease [2,213 B]
Get:3 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Get:4 http://packages.ros.org/ros/ubuntu buster InRelease [4,657 B]
Get:5 http://packages.ros.org/ros/ubuntu buster/main armhf Packages [21.5 kB]
Reading package lists… Done
E: Release file for http://archive.raspberrypi.org/debian/dists/buster/InRelease is not valid yet (invalid for another 10d 23h 38min 2s). Updates for this repository will not be applied.
E: Release file for http://raspbian.raspberrypi.org/raspbian/dists/buster/InRelease is not valid yet (invalid for another 15d 0h 58min 43s). Updates for this repository will not be applied.
pi@navio:~ $

Hi guys,

Thanks for the report! I’ll try to reproduce this behavior and write to you about the results.

Hi there,

It seems the issue isn’t related to the latest firmware. We weren’t able to reproduce that with our devices. Alternatively, you can reflash the SD card to the newest image if you want to update it.

Hi,

I installed latest image emlid-raspbian-20200922.img.xz on my RPi4B with 8GB.
It booted fine and I did sudo apt-get update && sudo apt-get dist-upgrade.
After reboot keyboard or any USB device connected to RPI stopped working.

Does it mean I can’t install updates if using emlid-raspbian image?
Is there any workaround?

Hi Alexey,

Some keyboards are not compatible with this kernel because they require additional configuration. The Emlid Raspbian image is mostly intended for drones control. Keyboards are rarely used there. So, I’d suggest using other options to control your Raspberry, such as SSH.

Hi again,

The problem is USB host controller which does not work after upgrade, neither USB3 not USB2 ports. I could use ssh, but the problem is that I need USB to connect cellular modem…

Summary:

  • Right after upgrade is finished, USB controller stops working
  • No error messages are visible in dmesg log
  • lsusb does not show anything
  • board reboot does not help
  • uname -a
    Linux navio 4.19.127-emlid-v7l+ #2 SMP PREEMPT Mon Aug 24 20:03:44 MSK 2020 armv7l GNU/Linux
  • hwinfo output:
    ----- sysfs driver list end -----

usb.2: usb
sysfs: no such bus: usb

  • Reproduction - 100% failure rate
  • if original image restored on sdcard, everything works again until next upgrade…

Could someone try to check these simple steps on RPi4B 8GB with Navio2:

  • install a clean image emlid-raspbian-20200922.img.xz
  • connect eth cable and do
  • apt-get update
  • apt-get dist-upgrade
  • check any usb device - keyboard, usb stick, mouse, etc…

∕alexey

Bad news:

Update done, check USB before reboot is fine

Capture d’écran 2021-02-03 à 17.46.09

After reboot, USB is broken

Capture d’écran 2021-02-03 à 17.57.37

Hi Alexey, Marc,

Thanks for the report.

We’ve reproduced the issue with the USB on RPi 4. We’ll be working on a fix. I’ll keep you updated.

Hey,

I got the excact same issue, though with a 4GB RPi4B.

I found a thread at the raspberry pi forum from January 2020, were a similar issue appeared to a few users, after updating the kernel version. As a (kinda temporarily) solution, it was posted to add over_voltage=1 (or =2) and force_turbo=1 to the config.txt file. This unfortunately didn’t solve my current issue, but maybe it will help fixing the bug.

Best regards

Hi @spacemonk-ey,

Thanks for sharing this! I’ll post an update here once we have any news.

Please do Svetlana! This just bit me with flight experiments next week. I have to re-create our whole drone software setup to revert back to the old version since we need the USB for the experiment.

Thank you!

OK, I found out which package it is. If you update just “raspberrypi-bootloader”, it will kill the USB subsystem in the kernel on next boot. I’m going to try to track down which /boot/fixdat or /boot/startdat is the specific issue and post it here if I can.

OK here’s a work around that worked perfect for me. I got the old contents of the “/boot” directory from a memory card with the August 2020 Emlid image and then copied over the newer files installed by the “raspberrypi-bootloader” update. It makes sense now, since I believe those proprietary binary blobs get loaded before the kernel even boots. If they’re not right then the kernel won’t even find the USB controller. I believe, it’s like the BIOS on a PC.

The cause of the lost of USB could be related to trying to boot a Emlid kernel from August 2020 with binary blobs that are supposed to be paired with a newer kernel. Or the blobs could just be totally broken. Anyway it seems to be these binary blobs need to stay with their intended kernel.

Hi Rick,

Thanks for your research! Sorry to hear that you had to rework your setup because of that. We’re working on the fix and will try to make it work as soon as possible.

Hey it’s all fixed now! I actually loved the nerd accomplishment. Like I said I think the kernel just need to match the binary blobs. Somehow you took your kernel out of the normal update process in Raspbian since you customize it. I think you just have to do the same for that other package. That way they get updated together or not at all. Perhaps I’m wrong about the connection though.

Hi Rick,

Sure, we’ll investigate that and check your assumptions. Thanks for sharing this! It might be helpful for other users, at least.

Hi Svetlana,
can you possibly make any prediction about when this issue will be fixed?
I need to make a decision on either waiting for the fix, or going into another direction with my project, and that would help.
Thanks in advance

Hi @spacemonk-ey,

We’re investigating this issue now and hope to fix it as soon as possible. It will also require thorough testing before it sees the daylight. That’s why I can hardly provide you with an estimation. However, I’m going to post all the news here once we have any.

2 Likes

Any updates on this issue?