"Update Rate" explanation please?

Hopefully someone from Emlid or someone that really understands this can respond please.

In ReachView, under RTK Settings, GNSS Select, Update Rate,1Hz,5Hz, 10Hz and 14Hz depending on the combination of GNSS Select of constellations chosen.

From another post of mine awhile back, I was having a problem of my displayed location and VERY slow movement in FieldGenius using Bluetooth, USB & Serial connection. i.e. it would take about 10-15 seconds for it to catch up and show my current rover location every time I moved, just terrible.

I had initially set it to 5Hz (and tried 10Hz and 14Hz) thinking the HIGHER the Hz, the faster and better update rate of the display of my rover’s movement. (kind of like the higher the frequency of a video display monitor refresh rate from lower quality 60Hz to 120Hz to 240Hz the better) Well, I changed it to 1Hz and it works flawlessly now and the movement is much better and workable in FieldGenius. Clueless why this is?

Is the fact that using a higher frequency rate such as 5Hz,10Hz or 14Hz, put more stress on the system introduce lag / delay? Therefore slow display lag when passed through to a third party software such as FieldGenius? What is strange is the ReachView app itself doesn’t show this lag in map view (which is great of course!).

Can someone please explain exactly what is going on with the Update Rate selection please? Is using a higher frequency more preferred or not? Why or why not?

Thank you so much for the help!


1 Like

+1… I think you might be onto something with the lag from too many pings vs the quality of the fix. I know we run 1hz base, 5hz rover and 5hz machine in construction. I was told to run the M+ at 14hz, but now I have the new firmware and the M+ at 5hz…


Curious, what kind of machine? Dozer or something?

Yes. We have dozers, blades and just got a couple of Komatsu excavators. Not so worried about the excavators as they are stationary most of the time and you can only dig so fast, but the others can run 10-15mph at times. Close to drone speed. They use GPS, Glonass and Galileo.


I think this may also be connected to the “messages” also? From what I understand too many messages and also at higher frequencies bogs the system down?


So in a way, the machines speed are dictated by the max update rate of the rover on the machine. So if I am thinking correctly, the higher the rate the faster and shorter the delay the machine. I.e max 14Hz for Emlid and the correct gnss constellation combination of course that works for the region. I’ve seen machines that use a Robotic Total Station at very high rates in order to keep up.

So getting back to it, just weird how setting to 1 Hz, my rover moves fluidly on the display (old Trimble Nomad 900G and Surface Pro 1 both with FieldGenius9). But when set at 5Hz or more, just huge 10-15 second lag from point to point while staking.

Maybe eventually the Emlid pros can explain why this works the way it does, in terms of GNSS.


I agree. The GPS system updates at 5hz. I guess because we are feeding from an existing (proposed) surface the rate isn’t as much of a factor as collecting data. Maybe we are getting better quality data on a slower rate?

Sidenote - I will be buying FieldGenius next week when they are open. Since I can’t figure out the last piece of integrating Magnet…


I’ve never used TOPCON MAGNET Field, but watched LOTS of videos etc on it. What is the last bit your having trouble with? I think u had a post awhile back about it? Was Brent ever able to help with it as I think he’s a Topcon guy?

Hi, sorry to just jump in here but I’ll leave my comments. I think I had the same experience where I could only get a fix in my Magnet software by slowing it to 1hz.


Ha! Speak of the devil! Here’s Brent. yes, I had it working but I really need to test again. I’m not exactly a “Topcon guy” but I do have a Topcon Robotic Total Station and I was really stoked how I could integrate these two products. I really need to test again and properly record every step.


@Brent_W, I will take a look at that. I think I have been running my rover at 5hz. Everything works great until I get a fix. I have gotten good data with a solid float and post-processing, but as soon as it goes green it won’t shoot and says waiting on the topo shot screen. Localization and other features work fine.


Have you tried adjusting the baud rate on the hamburger device?

By adjusting from 1-14hz you can see from strsvr app the bps (bits/sec) increases.
At 1hz, 4800 baud rate is enough.
A typical speed for nmea0183 at 4800 (8bit pr sign) baud would 4800*8= 38400bit/sec


Wow. : )

But it doesnt sound right the symbols or charcter in this application is 8 bits. Sound its way less. More like 1 or 2 bits pr symbol.
Read page 2 here

1 Like

Some more info to rule out confusion

2400 baud. 9600 bps. These are familiar terms for any modem user.

The terms baud and bps are often used interchangably. However, the two are not the same at all.

The carrier signal is characterized by the number of signal intervals, or pulses, that are transmitted per second. Each pulse is called a baud .

Bps stands for b its p er s econd. Bps is a measure of how many bits can be transmitted during one pulse (one baud). So,

bps = baud * number of bits per baud .

The two are often confused because early modems used to transmit only 1 bit per baud, so a 1200 baud modem would also be transmitting 1200 bps.

These days, we need higher speeds. But for two-way communications, the baud limit is 1200 baud. So the technique is to try and “pack” as many bits as you can into 1 baud.

A modem operating at 9600 bps is still only transmitting at 1200 baud. But it is “packing” 8 bits into each baud:

9600 bps = 1200 baud * 8 bits per baud .

The general technique for “packing” bits into a baud is called quadrature amplitude modulation .



That is true for QAM modulation Modems, And other complicated modulations.
But for the modulation used by the over the air modems that reach uses, bps = baud AFAIK.

1 Like

Awesome, that seems to make sence from what i saw in the log.

By air, you do you mean wireless or all kind of transmission?

So what’s the default baud rate of the Reach RS+. Topcon defaults to 38400.

Whatever your heart desires, it seems: https://docs.emlid.com/reachrs/common/reachview/correction-input/#serial

Thanks @wizprod! I am guessing like the Topcon that it negotiates. My FC-500 is set at 38400 and I haven’t had any issues connecting or with the majority of communications. Just let it be.

@timd1971, I bought Field genius and I stalled 10 on my FC-500. I guess I know what I am doing this afternoon. Start reading the PDF when I get home!