Update rate does not get set

In TCP NMEA setting I am able to select 5 and 10Hz however when I apply it’s forever being in progress of change (double arrow turning) and never happens (stays at 1Hz).

I tried it thru TCP local network thru web app and reachview android app. I don’t have a serial port and I didn’t found a way to do it thru USB so I figure we can’t.

please let me know what to try.

Simple system report
app version: '26.2'
current_network:
  ip: 192.168.0.120
  security: wpa-psk
  ssid: BRUTUS WIRELESS
enabled: true
mode: client
base_mode:
  base_coordinates:
    accumulation: '120'
    mode: single-and-hold
  output:
    io_type: 'off'
    settings:
      cloud:
        mount_point: ''
      lora:
        air_rate: 18.23
        frequency: 902000
        output_power: 20
      ntripsvr:
        address: ''
        mount_point: ''
        password: '***'
        port: -1
      serial:
        baud_rate: 38400
        device: ttyEXTS0
      tcpcli:
        address: localhost
        port: 9001
      tcpsvr:
        port: 9000
  rtcm3_messages:
    message_1002:
      enabled: true
      frequency: '1'
    message_1006:
      enabled: true
      frequency: '0.1'
    message_1010:
      enabled: true
      frequency: '1'
    message_1097:
      enabled: false
      frequency: '1'
    message_1107:
      enabled: false
      frequency: '1'
    message_1117:
      enabled: false
      frequency: '1'
    message_1127:
      enabled: false
      frequency: '1'
bluetooth:
  enabled: false
  pairing:
    discoverable: true
    pin: '***'
correction_input:
  base_corrections:
    io_type: lora
    settings:
      bluetooth:
        send_position_to_base: false
      cloud:
        mount_point: ''
        send_position_to_base: true
      lora:
        air_rate: 18.23
        frequency: 902000
        output_power: 20
        send_position_to_base: false
      ntripcli:
        address: gps.can-net.ca
        mount_point: qcvrscmrx
        password: '***'
        port: 2350
        send_position_to_base: false
        username: ''
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        send_position_to_base: false
      tcpcli:
        address: localhost
        port: 10001
        send_position_to_base: true
      tcpsvr:
        port: 10000
        send_position_to_base: true
device:
  power_on_bottom_connector: false
  privacy_policy_accepted: true
  role: null
  usage_analysis_accepted: true
logging:
  logs:
    base:
      autostart: false
      format: RTCM3
      started: false
    correction:
      autostart: false
      format: RTCM3
      started: true
    raw:
      autostart: false
      format: UBX
      rinex_options:
        logging_interval: 1
        marker_name: null
        pole_height: null
        satellite_systems:
          beidou: false
          galileo: false
          glonass: true
          gps: true
          qzss: false
          sbas: false
      started: false
    solution:
      autostart: false
      format: XYZ
      started: false
  settings:
    debug: false
    interval: 23
    overwrite: true
position_output:
  output1:
    io_type: serial
    nmea_settings:
      bluetooth:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: false
          update_rate: 1
        gst:
          enabled: false
          update_rate: 1
        gsv:
          enabled: false
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: false
          update_rate: 1
        zda:
          enabled: false
          update_rate: 1
      tcpcli:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
    settings:
      bluetooth:
        format: NMEA
      serial:
        baud_rate: 115200
        device: ttyGS0
        format: NMEA
      tcpcli:
        address: localhost
        format: ERB
        port: 9000
      tcpsvr:
        format: LLH
        port: 9001
  output2:
    io_type: tcpsvr
    nmea_settings:
      bluetooth:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpcli:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: false
          update_rate: 1
        gst:
          enabled: false
          update_rate: 1
        gsv:
          enabled: false
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: false
          update_rate: 1
        zda:
          enabled: false
          update_rate: 1
    settings:
      bluetooth:
        format: NMEA
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        format: ERB
      tcpcli:
        address: 192.168.0.111
        format: NMEA
        port: 22
      tcpsvr:
        format: ERB
        port: 9001
positioning_settings:
  elevation_mask_angle: 15
  glonass_ar_mode: true
  gnss_settings:
    positioning_systems:
      beidou: false
      galileo: true
      glonass: false
      gps: true
      qzss: true
      sbas: true
    update_rate: 14
  gps_ar_mode: continuous
  max_horizontal_acceleration: 7
  max_vertical_acceleration: 2.1000000000000001
  positioning_mode: kinematic
  snr_mask: 35

What is your rtk observation rate set to?

It’s the original settings.
Settings are attached in the questions.
It’s of course lower than rover output but I was under impression from the instructions that it doesn’t matter… Am I wrong?

It says update rate 14?

I do not work for Emlid, so is that 1,5, or 10hz? or coded info like 4 at 1hz

In short it will not work well if your observation rate is 1Hz, and your position output rate is 5 or 10hz.

Your observation must be the same or higher than the output rate.

Thx unfortunately I won’t have access to it this week. I ll try higher rtk rate when I ll be back and let you know. But instructions are not giving any information for rtk. Probably because you could still use the devise with rtk off… Don’t know…

Hi Charles,

Thanks for sharing the report!

I’ll take a look at this and will try to reproduce it. I’ll get back to you once I’ve any news.

Hi Charles,

Please check your PMs. I’ve messaged you there. We need some sensitive information so that it’s better not to post it publicly.

Hi everyone,

Let me conclude this topic.

There can indeed be difficulty with choosing the 10 Hz output rate when you’re working with the 14 Hz update rate. The update rate has to be divisible by the output rate.

To use the 14 Hz update rate, you will need to choose 1 Hz in the NMEA output rate. We’ll add this information in the docs and in the app.

In case you require higher output rates, please, work with the 10 Hz update rate and the 10 Hz output rate for the Reach receiver.

2 Likes

Hi everyone,

We’ve released the new stable version of the firmware - 26.3 Reach Firmware. Now, it doesn’t allow to set NMEA update rates if the RTK update rate isn’t divisible on it. So, there is no need to perform additional calculations from now on :slightly_smiling_face:

Thanks for drawing our attention to it!

5 Likes