Update and wifi connection issue with Reach and dev. 2.21.1


I’m trying to do a firmware reflashing for Reach RTK.
And my problem is finding the v2.22 firmware download for Reach RS / RTK.
When i look at the docs (https://docs.emlid.com/reach/common/reachview/firmware-reflashing/#flashing-process-for-v2211) it only show a download link for Reach Image v2.20.8 and not for v2.22.

I’m new in the Emlid world. Thanks for your help.

Use the image 2.20.8 and flash. Then do an update


Thanks for your help.
I have now used the image 2.20.8 and flash. I have restarted the Reach RTK and open the app. (Because this is where I expect to be able to press update)

I have attached a screenshoot from the app (ipad), but it keeps asking me to do the firmware update, as you can see in the picture.


Are you able to force update by pasting this into browser?

Edit2: what happens if you enable dev. updates. Does it allow you to update then?

If not, Reflash with the current Dev version might be a better way.

  1. By using the browser it results in this screen:

  2. How do i enable dev. updates?

  3. i tried using the “Reach Firmware flash tool”, resulted in this:

Any solution proposal?

There is a tooth wheel in top right corner in the menu to the left. Try that first.

I assume you refere to the Control panel.
Hvis is screen shot of my control panel, and I do not see any thing regarding dev. updates

I see. Then your are left with downloading the dev. file and flash it.
The one to the right in the link below

Edit: @Emlid, is this a new bug? I reckon updating from 2.20.8 to dev before. ref link below

Thanks, but is still making problems.

I have now flashed the dev. to the Reach RTK. but one “accident” does not come alone!
After the new flash, will it not connect to my wifi! (It worked fine before)
I have now tried to connect it 10 times, either by configuring it in the app or browser.
So i cannot get access to the internet, and there by not update… ?

You can connect to Reach hotspot?
Do you have the antenna connected?
Does it help if you have the antenna i somewhat clear sky to let it sync
If you add :5000 at the end of the IP adresse, what do you get?

Edit: One more thing, is your Wifi handing out IP addresse in the range of 192.168.2.xxx ?
If so, try share wifi with your phone and let Reach connect there instead

If your Reach is not connected to internet, it will not inform you of updates.

sorry. I wasn’t specific enough.

The reach create a hotspot, that I can access. So this works fine.
I connect to it over :5000 and configure the wifi I want it to access, and press connect. It then close it own hotspot for a while (2min), but then it opens it own hotspot again.

  • I’m using my iPhone as hotspot and it hands out IP: 172.20.10.x on subnet

  • Yes, the antenna is connected.

  • No, right now i’m indoors, but this worked fine in the non-dev. firmware.

And you have tried turning the power off for Reach for few minutes and then on again after wifi has been added?
On your phones, do you see it connect before it drops the connection?
You have tripple checked the password is correct typed in?
Try changing wifi password to something different and simpler

I have already tried all the idears you mention here.
Non of it works.

And, no. I don not see it connect before it drops the connection.

This part here. Is that how you configure it each time? Not through the Reachview menu?
Oh, and are you Norwegian? It stats Ons in the display

menu? i have used both the app and browser.

hehe. almost. i’m danish. :slight_smile:

I`ll try my own unit later and see if it will act up too.

I have now downgraded it to v2.20.8 and the wifi is working fine now.

Updated Reach from 2.21.2 No issues here
Was running 2.21.2 thoug

1 Like

Did the same this morning without any problem .

1 Like

From 2.21.2 ?