UART to RS232 NMEA output

I am using a Reach RS2 with latest Firmware and am attempting to output an NMEA string via the EXT port and a RS232 cable to a serial-to-USB converter on my Panasonic Toughbook.
I am checking the port with Realterm and YAT but no data is received, despite all parameters (Baud rate, stop bits,…) set correctly.
I am at a loss what I may be doing wrong here.
Is this an UART to serial RS232 conversion problem?
How can I solve this?
Any tips highly appreciated!

This might be a bit basic, but worth posting just in case: Have you checked that tx goes to rx and vice versa? If in doubt, try a null modem to make sure

What is your assigned com port number?
Are you running a speed that is at least 38400?
Have you loaded the driver for the serial to USB converter, does it have the ever handy diagnostic lights?

And as above try a null modem.

Did you setup NMEA output to serial on the RS2? Baud rates need to match on the RS2 and in RealTerm.

Hi @immo.trinks,

Welcome to the forum!

Did you have a chance to test our users’ suggestions? I’d pay extra attention to the pinout of the connection and the baud rates: TX on RS2 should match RX on your converter, the baud rates should be the same for when you send the data and receive it.

Please keep us in the loop on how it goes for you!

Thank you all very much for your suggestions and help! There was nothing wrong with the EMLID REACH RS2 or the settings. Actually the problem was the serial-to-USB converter. I tried three different ones and they did not work. Then I could borrow a top of the range converter (https://www.meilhaus.de/usb-2com.htm) from a colleague and I got the data stream immediately into the RealTerm App on my Panasonic Toughbook. Here the adapters that I have tried, the red one actually worked:
https://photos.app.goo.gl/bMByqAkuuZZmAzBz9
I have now ordered two of these converters and am looking forward to using the RS2. Yesterday we were continuously precisely positioning high-resolution sidescan sonar measurements with the RS2 receiving corrections via NTRIP using this setup: https://photos.app.goo.gl/B98Ttf9NGNyeLj3p6

Hey @immo.trinks,

Thanks for the update, great you found the root of the evil :slight_smile: Be sure to share the results of your further work with us!

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.