UART issue with GPS

I have a new navio build and am having a problem anytime I have the 3DR radio via UART port or via USB (w/CP2102) I dont get any GPS when I start up the pi.

I can plug in the 3DR radio after the navio has been on and with GPS lock already, but then I get erratic position hold, as clearly visible on the chart below after the 4min mark. I have tried AC3.4.6, 3.5rc6 and 3.6dev and same issue, have tried different cables and moving then GPS and 3DR radio farther appart and nothing, also tried alum foil, no luck…
what could be going on here? I have also reinstalled the image 3 times…

I have a copter with a pixhawk which works flawlessly with 3dr radios. My rover with RPi3 and Navio2 not so much. As soon as I connect the 3dr radio v2, GPS lock either degenerates over time or it does not get a lock at all. With the V1 radios, the digital steering servo starts to twitch and hum.

yea there is definitely something off going on electrically in terms of conflict between the 3DR radio and the Navio for sure…right now I have the 3DR radio connected via UART and have no GPS lock (not even picking up any sats) even thou I can make a radio connection from MissionPlanner to NAvio2 via 3DR radio just fine…but again, no GPS
then if I unplug the red 5V power from the UART connection, then GPS shows up on reboot, but then of course I have no radio!!! ugh…am going to power the 3DR totally independently next and only have RX/TX between Navio2 and 3DR radio and see what happens

for sure an issue with compatibility or something that Navio doesnt like about the 3DR modem…I hang off a minimosd of the same UART port and it works fine and GPS works fine too, so is not a cabling or setup issue as minimosd is displaying all the mavlink data correctly and same baud rate…not sure where go from here, Wifi wont ever get me the same distance that a 500mw 3DR radio will, so thats not the answer…

I think it is both radio interference and interference travelling through the wiring. I also tried to wrap a radio in aluminium tape, but that changed nothing. One thing I did not try, is to power the 3dr radio from a seperate BEC or to put filters between radio and Navio.
I just wanted to use the 3dr radio as a backup for the wifi connection the rover uses for control, telemetry and video, so I just did not try anymore.

well get his, apparently is just an issue with the 3DR 433mhz unit, if I use the 915mhz unit instead, it works just fine, no problem at all…somehow the built-in GPS on the Navio is getting interference from the 433mhz band, which is weird because I thought GPS operated on the 1.4ghz range

and why the heck did EMLID bother with embedding a GPS in the board? when there are tons of cheap GPS units that can be just plugged in and have solid track record…I would have rather much have had 2 or 3 physical UART ports than the embedded GPS unit…because I want to control my storm32 gimbal via mavlink using UART…but with just one UART port is kinda impossible…

You can always use USB to Uart adapters if you need more ports. The Raspberry Pi does only provide one UART port and the Navio board has a convenient connector for it.

gotcha, I do have several CP2102, but is a bit clumpsy with them, but it can do the job I see, I wonder if the PI has enough power amps to handle all those things connnected to it via USB

A post was merged into an existing topic: /dev/ttyAMA0 Missing in Emlid 2017-03-23 Raspbian


Raspberry Pi only has one serial port available on the 40-pin connector, so we included GPS over SPI in order to leave the only UART port available for users. If GPS was external there would be no Serial available for telemetry.

1 Like

makes sense now, thanks