Troubles with the stabilty of Reach RS2

Reach RS 2, Firmware 27.1
IOS 15.0.2
Vodafone Card

After using the Reach RS + for over a year, I bought a Reach RS2 two months ago.

The device works extremely unstable and unreliable in some places, as it constantly crashes and reboots shortly after booting. It may boot 3 to 4 times before you finally get a result, but you have to be quick then. It takes half an hour or more to record 5 points. Sometimes the device beeps continuously during booting since the previous reset. Then only a manual restart will help. According to my observations, the behavior mainly occurs when the cell phone reception is not absolutely perfect .

I tried to see if the WiFi had an impact by turning on the access point on the Iphone. Sometimes it feels like an improvement, but mostly it doesn’t. I don’t now what to do now, especially since the device is completely new and I don’t use it much. But when I need it, I have to be able to rely on it because the project locations are far away from the office. Is it a software or a hardware issue. Should I return it to the dealer? What is confusing is that I’m the first one to report such an issue…

I’ve attached the logs of a mission from yesterday. You see 8 boots but there where more in reality!

Log Files


I didn’t look at your log file as I do not know if it would tell me anything or not but, what setup are you using? RS2 as a base? RS2 as a rover with corrections? If receiving corrections, how? LoRa radio? NTRIP via hotspot or internal modem? Too many variables for most of the forum members (non-Emlid official)
to fathom a guess.

1 Like

Im using RS2 as a rover with corrections, which are received by NTRIP via the internal modem. The SIM card is from vodafone which is normally a pretty good choice regarding network coverage. The NTRIP service is provided by the local authorities and I never had an problems with it. Hope this helps.

The unit is clearly not working as designed.
Contact Emlid support directly. That will give you the best and fastest support in this case.

1 Like

Hi Heinrich,

Christian is right: it’s not normal behavior for Reach RS2. We need the Full system report from the unit. It contains much more info about the system but also some sensitive data. So, please send it to I’ll take it.

One more important clarification: does the unit reboot without the SIM inserted?


Hi there,

To anyone concerned about this issue: I’ve received an email from Heinrich. I suppose we’ll continue communication there, but I’ll keep this thread updated.

If you face the same issue, please share the report to as well.

1 Like

I can confirm that I faced the same issue today in the field. RS2 Rover with 27.1 firmware connected to NTRIP via internal SIM card. It was an area with patchy data coverage. Once the FIX with the NTRIP was lost, the unit would automatically reboot after a few minutes. In addition, upon reboot, and even after obtaining a FIX, the Bluetooth connection was not reliable, and I had to reboot the device again for Bluetooth to work. This happened on several occasions. During the previous days with no loss of data coverage, the unit worked fine. So there is definitely an issue here using NTRIP in areas of poor data coverage with the RS2 and 27.1.

Hi @lucas,

Please share the full system report with us at Also, we need to know your SIM card provider and if the issue repeats without the SIM inserted. We’re still investigating this issue with Heinrich, but your report may help here as well.

I can send you the details once I finish fieldwork in the upcoming days. Today there was no problem for me, but I had a continuous connection with mobile data.

Sure, just write to us when you’re ready to troubleshoot this.

Hi there,

We found out that Heinrich faced a rare hardware malfunction. So, we decided to replace the device. If you face similar behavior, please reach out to so that we could investigate that.

1 Like