To NTRIP or not?

Hi.
After some time and a reflash of the firmware (i had issues with the set up), i now have my two Reach RS+ units functioning and communicating to each other.
I’ve also done a small test survey of my garden and exported the data to dxf (my main reason for use) although the point data does not appear next to each point i suspect i will have to input the coords via script so that point id data is attached to each one?
I will be using the Reach rs+ units for topo surveys and setting out gcp’s for uav aerial surveys.
I’m likely to be out on agricultural land in the middle of nowhere most of the time and will not have access to internet data.
How realistic is cm (sub cm?) accuracy using a reach base and reach rover operating over LoRa?
GCP data for the uav surveys is key tie in the drone data so need these as accurate as possible.
I will be the one setting out GCP’s as an external contractor so having m-reach or rtk on the drone is not an option so i will be providing GCP mats and attaching coords to them.
Sorry if that sounds confusing…
So my main question is, by setting up the reach base which will be set up over an unknown point just a peg i put in and then using the rover to collect point/GCP data, will this provide good accuracy?
Thank you in advance for your help, i’ve had really good responses from you guys so far!
Michael.

Hello Michael,

First welcome to the world of surveying!

I suggset to convert collected data from Geographic coordinates (LLH) Latitude, Longitude, Ellipoid Height to X, Y, Z (WGS84 UTM Zone X) format used by your Region (You will find a lot of converters in the net) , and import them by any DAO software.

Or simply use a third party application :

https://docs.emlid.com/reachrs/common/tutorials/mock-location/

If you use LoRa for RTK data collecion In the line of sight, the baseline may reach up to 8 kilometers.

Else you can Post-process your data following a tutorial below :

https://docs.emlid.com/reachrs/common/tutorials/ppk-introduction/
https://docs.emlid.com/reachrs/common/tutorials/gps-post-processing/

If you have a lot of points to collect you can use :

Point extractor “ Posprocessor v0.3.0

Of course your survey remains with centimeter accuracy if the base is in the range of 10 km in kinematic mode.

3 Likes

Thank you very much for the info.
I am back to square one again with connection issues now though and cannot connect to the Reachview app. The Rover is in the device list but when i click on it it hangs for a while and then says Reachview is not working.

@michaeldroberts1975 Do you use hotspot?
If yes Try Google chrome to connect using IP adress 192.168.42.1

It says site cannot be reached.

What are you using for design? That will determine the best way to configure the data. Most CAD and GIS programs should be able to use the points file as it comes out of Reachview. Even Google Earth pro does.

It depends on the local conditions. As long as you have a good sky view and clear line of site you can rely on getting about a mile in each direction from the base. I don’t think 8km is realistic for most conditions with the + units.

So you are setting the GCP’s and someone else is flying the drone? Why not do both?

This will depend on the scenario. You will need to match the coordinates of your end product and/or clients needs. This could be really easy or become a little more complex in many different ways.

Confirm whether you are connecting to the receiver’s hotspot or if it and your device are connected to another WiFi?

1 Like

Thanks Michael, i really appreciate your response!
I’ve exported a file as dxf and opened in Autocad but there were no labels/text attached to the points which is a necessity as far as i’m concerned. Only if i selected the point did i get the properties info in the properties sidebar but not the point names i inputted. I also have to scale up the dxf drawing by around 100,000, should i have to do that?
I do have my Pfco for commercial drone ops here in the UK but seeing as surveying is now a part time gig for me, i help out a guy i do some drone work with.

Ok, so you were able to get the points in CAD, but cannot see the text attributes?

Is this regular AutoCAD? Or maybe Map or Civil 3D?

Did you bring in the LLH or did you convert to a Cartesian XYZ coordinate system?

I’m using full AutoCAD 2020.
After finishing the survey (only 10 points as a test) in the Reach app i exported it as a dxf file.
I then simply opened the dxf in AutoCAD.
I expected the points to be visible with point labels or numbers at least attached.
The survey was done in LLH format in the Reach app.

1 Like

Gotcha. So first thing is that the DXF export is only the node. Also, make sure the units between the DXF and CAD match. If they didn’t I would expect the standard imperial to meters factor or vice versa, but I am not sure about what you are experiencing. Maybe the file is still in LLH and meant for GIS import? I never use the DXF, but will download one of mine to see what it does.

Also, standard AutoCAD cannot natively handle points with attributes. If you could get the points in XYZ try downloading the CSV and using this LISP routine.

http://www.hawsedc.com/gnu/pointsin.php

Either way I would encourage you to look into a CAD software designed for mapping if you are going to continue doing this kind of work. Personally I would recommend Carlson Survey, but there are less expensive options that would require a little research and/or trials to see if they can do what you need. Carlson is a far better option than Civil 3D or Map and since you have the latest AutoCAD you can use it with Carlson to maintain all of your typical AutoCAD menus. A perpetual license of Carlson is also the same price as a one-year subscription of Civil 3D. You can then pay 10-15% annually to remain on maintenance for version upgrades if you want, but it is not necessary.

http://www.carlsonsw.com/solutions/land-survey/survey/

1 Like

I will also say that if you are using Reachview 3 you can use local coordinate systems instead of just WGS84 or ECEF like in Reachview 2. I believe the majority of them are available now.

Unfortunatley Reach View 3 isn’t available for ipad mini.
The Reach set up is not working on my iphone or Android CAT S61.

As this is just a bit of side line and more of a hobby really i can’t justify the cost of CV3D or Carlson… AutoCAD is what i use as a product development engineer so i already have that and to be honest it’s what i’ve used since starting surveying around 20 years ago.
The Emlid system is the most confusing and un user-friendly i’ve ever used!

Reachview 3 should be available on Android if you wanted to try that.

Undeerstood. $2k isn’t easy to come up with, but keep it in mind if your business progresses. It will be well worth it. For just shooting in GCP’s (if the LISP doesn’t work) it doesn’t seem like it would be too cumbersome to create a block with attributes that you could just load to each node and then fill in the data. You already have the XY so entering Z and Description should be pretty easy.

Just curious, but what kind of “surveying” have you been doing for 20 years that you have gotten by with just standard CAD?

What kind of survey systems have you been using? In my opinion the Emlid systems do exactly what they are designed to which from a Surveyors perspective is GIS work, but they have been working hard with us to redefine the product and are getting closer to what I would consider a true survey solution everyday. I think you might see some of this if you tried Reachview 3. Coming from a Trimble and Topcon background Emlid’s systems are actually quite simple in comparison.

Don’t forget to clarify your current method of connecting to the receivers.

2 Likes

Taking a look at the DXF and CSV you provided. Is this the general area of the survey?

This was what I was thinking the problem was earlier with the scale is the fact that the DXF is the points in WGS84 LLH which standard CAD cannot use or convert from. You will need to bring these points into a GIS software like QGIS, transform them to your local CRS and then bring them into AutoCAD. Then perhaps the LISP routine will get you the rest of the way. As an alternative maybe QGIS would suffice for the 99% of your workflow and then that could always be brought into CAD as a DXF later if needed.

Unfortunately my Android phone cannot connect to Reach or Reach 3 today or my iphone. This is what’s frustrating, i get somewhere with it and then it just stops working.
I’ve worked on large flood defense surveys for the EA, HIghways for local authority and general redevelopment work so it’s been a big variety. All software has generally been company owned but when i’ve worked for myself and had my own Leica kit CAD has been perfect for creating topos. I’ve never done big work to require contours so that was always a bonus and probably been where CV3D would have been justified.
I had a nifty GSI-DXF conversion software package that i’ve used and still use if i’m doing any total station work. All my work has mainly been topo total station work and manually levelled to BM’s.
I used Trimble gps kit at Cheshire County Council and from what i remember the processing was pretty straight forward.

2 Likes

Yes, that looks about spot on for the area.
This is where Emlid falls short in my view… or i should say doesn’t do what i expected personally so probably my fault for not researching it correctly… there are a lot of processes to go through for the end result… i’d hoped i could just export it out and it would be usable.
I think i’ve decided on the selling them anyway now so if i can’t get it all working without any extra expense over the next few days they’ll be going.

Do you know your local Cartesian (projected) XYZ coordinate system? I am transforming the points in QGIS now.

This is the misunderstanding. Reachview is the problem, not the hardware. As designed Reachview 2 (in my opinion) is GIS surveying software. It only works in WGS84 and ellipsoid, cannot do localizations and does not transform on export. If we can get Reachview 3 to work at least on the phone and gain the ability to use your local system then the export would be straightforward minus your CAD’s incapability of dealing with survey point attributes.

We still don’t know if you are connecting directly to the Reach hotspot or if the Reach and mobile device are on a WiFi network?

My local coordinate system is OSGB36.
I really do want it to work as the way my mind works i like to get lower end kit to function as good as more premier ones… i always got by with my Leica TCR1105 and gsi-dxf software and produced as good results as big bucks equipment like the TS range albeit a little slower… alas i did find i needed to invest thousands to speed up the process and i’m afraid that’s where my full time surveying ended… hence me wanting to get this up and running to get a foot back in the door.
Sorry for the sob story ha ha ha… just trying to explain i’m not thowing the towel in without having a bloody good go at it.
As i say i’ve had these units around two years and everytime i’ve tried to get them up and running i get frustrated at how much effort is needed as i’ll be using them in my own time evenings and weekends etc so i want to be able to set them up and go to produce results quickly… which i now see is probably not the case.
The units are linked by their own hotspots, LoRa to eachother and to my ipad via wifi from the rover.
They’re both connected fine now and able to carry out a survey but the same happened yesterday and then it took hours this morning trying to get them connected again.