TFmini scaling error

I have installed a TFmini range finder and have the output on Mission Planner.

It is out by a factor of about x 3.25, it reads 4m at 1.23m

As it’s data, I don’t see a way in MP to scale this. I would have expected there to be a multiplier somewhere.

Ardcopter FW V3.6.11
Mission Planner 1.3.70

Is working fine with the software (1.23m)

I have upgraded to 4.03 and this problem remains.

Sonar reads 4m in Mission Planner at 1.23m

Benewake app reads 1.23m

Does anyone know where I can edit the multiplier?

Hi Lee,

I’m afraid we hardly can be of help with configuration of 3rd-party equipment.

Have you checked this tutorial related to the TFmini lidar arrangement from Ardupilot docs?

There is a parameter to look:

https://ardupilot.org/copter/docs/parameters.html#rngfnd1-scaling-rangefinder-scaling

rangefinder1 (TFmini)) and rangfinder2 (analog) values are both perfect.
It was my misunderstanding not to observe these values in status.

Sonar Range is incorrect.

I don’t see where this is obtained.

Hi Lee,

Thanks for your patience.

Had you checked this thread by Marc? In includes all the configuration parameters that work just fine with Navio2.

As Anastasiia already said, I’m afraid we can’t be much of help with the configuration of the 3rd-party equipment. However, there are TFmini representatives on the Ardupilot site. They will be able to provide you with an answer regarding their equipment.