Telemetry 3DR SikV2 doesn't connect to GCS Mission Planner

Hello world!

I’ve been stuck on this issue for several months now, and after ordering a new SikV2 radio, reinstalling Navio2, it still didn’t solve the problem.

Posted are screenshots of my settings.

Emlid Raspbian 4.19.83
ArduCopter 3.6

Cannot connect telemetry to Mission Planner or APMPlanner.
Telemetry kit connected via UART port on Navio2, both lights solid green:
https://store.mrobotics.io/mRo-SiK-Telemetry-Radio-V2-915Mhz-p/mro-sikv2.htm

Goes to “Trying to connect…”, times out, “No heartbeat packets received”
UDP works though, but if I want to bring it out to the field, telemetry to GCS would not work then.

/etc/default/arducopter:

Parameter settings (connected via UDP):

RealTerm serial input from my Windows 10 laptop, after entering ‘asdfasd’

  1. If using any additional hardware please provide exact make and model.
    Raspberry Pi Camera V2

If there is any more information you need to help figure this out, please let me know!

Thank you,

Hi Vegeta,

May I ask you to share a picture of your setup?

Have you tried connecting the telemetry module via a USB port? Does it work that way?

Also, can you check if your module appears in /dev/ folder after connection?


Just tried USB by TELEM2="-C /dev/ttyUSB0" and it did not work either.

cd /dev
ls -l serial*
image

Hi Vegeta,

According to your terminal output, it seems, that Raspberry detects the transceiver.

Can you also print the following command in the terminal after the connection:

dmesg | grep tty

Moreover, I’ve been trying to reproduce your setup lately. And I’ve experienced a missing driver issue for Windows 10. Does your Device Manager show any warnings?

Finally, two more questions. Is there no telemetry red LED’s light at all? And do you have a JST cable without 4th and 5th wires for CTS and RTS by any chance?


I’ve been using this driver for the radios. Let me know if that’s even the correct one.

Connected via USB:

Connected via UART:

Red LED’s flash. when I use screen on the Pi, and Realterm on PC, the garbled messages and red LED’s are in sync as I press/hold on my keyboard. I couldn’t figure how to make serial input readable though…

I do have a JST cable with female connector ends.

Thanks,

Hi Vegeta,

In the Mission Planner via UPD connection can you try changing the Serial1’s baud rate to 57? I guess, there’s a baud mismatch between your PC and a drone.

Holy moly, finally got it to work.

I changed Serial0 to 57, but that didn’t work alone.
I guessed on unchecking RTS CTS and Op Resend on the SiK Radio.

Why does changing Serial0(Telem1, UDP connection) work on fixing the telemetry radio(Serial1, Telem2)?

Thank you Mikhail for all your help!

Hi Vegeta,

Nice! Glad that you’ve solved that issue.

I believe, the issue was connected with a CTS and RTS wires (clear to send/request to send). As far as I know, there were issues with setting up a telemetry via radio when the CTS line is connected.

If you feel like experimenting, I’d love to know what was the catch exactly.

Hi Mikhail,

I’ve done a standard update and upgrade, and now the telemetry is not working like before.

The telemetry module works only via USB on the RPi, and the UART port doesn’t let Mission Planner to connect. Below are snaps of some settings when it DOES work via USB.



MAVProxy

image
Doesn’t connect to air module anymore

Both GCS and air modules are solid green, once I press connect, both flash red lights for about 3 flashes, then quits and fails to connect.

Any help would be greatly appreciated.

Dinh

Well, solution found.

I’ve just tried various things, but I plugged in the JST-GH AND the microUSB into the air radio module, set the serial rates to 57 and MAVLINK2 and the quality and speed of communication improved drastically from 400 B/s, 9% quality, to 2.8KB/s, 100% quality.

image image

Hope this helps anyone with this same problem and just a reminder to just try random things :slight_smile:

If there’s an explanation for why plugging both USB and JST connectors work that would be so helpful.

Cheers~

Hi Dinh,

I was just going to write to you with results of reproducing your setup :slight_smile:

I’ve used two radios. One connected to the GCS with USB and second with UART connection to Navio2 (5V, RX, TX and GND wires only). In my /etc/default/arducopter file I made the following entries:

TELEM1="-A udp:192.168.4.12:14550"
TELEM2="-C /dev/ttyAMA0"
ARDUPILOT_OPTS="$TELEM1 $TELEM2"

I’ve also checked the connection with your MP settings (baud and protocol) and it’s ok.

Since the connection was not established via UART and USB was OK, I suppose that with both radio module’s ports connected to your autopilot, ArduPilot is choosing the USB for telemetry. That makes me think that there’s still something wrong with the UART connection.

On one of your screenshots with radio settings, I see that the remote radio settings are faded. Probably you need to uncheck RTS CTS on the Navio2’s side too to make UART work?

Hi Mikhail,

Yes you are correct that the drone is choosing USB for the telemetry comms; I’ve disconnected the UART port and these are the stats I get (I’ve tinkered with it a bit by disabling signing and setting all serial to MAVLINK2 to improve the speed/quality):
image


image
image
RTS CTS has always been unchecked.

UART still doesn’t work; I have three pairs of telemetry modules and the only pair with USB works.

I’m getting HUGE compass/GPS variation through telemetry versus UDP, there is also a lot of delay from issuing commands from GCS.

If there’s anything you think I should try or take pictures of, I am very happy to help figure this out.

Cheers,
Dinh

Hello,
at the moment, I am facing the same issue and therefore rather answer to this conversation instead of creating a new topic.

Emlid Raspbian 4.19.127
ArduPlane 4.0

Computer: MacOs Catalina 10.15.7
APMPlanner 2.0

Connection via UDP works without any issues. I have connected my telemetry radio via UART-Connector. Both radio LEDs turn solid green then. I also physically disconnected CTS&RTS Pins. This made the red LED on the raspberry side flash continuously. When I disconnect the UDP connection, I am able to load, copy and save setting for the radio via APMPlanners 3DR Radio Menu (both red LEDs flash then).

So the connection itself works via cu.SLAB_USBtoUART and 57600 Baudrate. So I expect the issue to be on the raspberry side, as communication initiated from the Mac works fine.

dmesg | grep tty

cd /dev/
ls -l serial*

nano /etc/default/arduplane

After several failures with the standard configuration, I changed Serial0_Baud (from 115 to 57) and Serial1_Protocol (from 1 to 2).

I have tried a lot of random stuff. Connecting the radio via USB doesn’t even make the red LED flash. But I still have the feeling that the Navio2/Raspberry-part does not try to make a telemetry connection. I am running out of ideas. I just cannot establish a telemetry connection. Can someone help me?

Thanks in advance!

Niklas Bommersbach

Hello,

just for others, that may have the same problem.
I was able to figure it out. I installed Windows on my Mac via BootCamp and tried to connect via Mission Planner. After Mission Planner “initialized” the telemetry modules, both red LEDs started flashing red.

Then I restarted my Mac on the Catalina Volume and everything worked great with APM Planner. I can’t really understand what the difference is, but it worked that way. The only problem I have right now is that I am not able to get GPS fixed while connected via telemetry. I am going to discuss that in another topic after I tried several things out.

Niklas

Hello,

I use Mission Planner only with W10 PC. No bootcamp installation on my Mac, only QGroundControl and Sik radio connection is fine. It could be a driver missing in the W10 installation. I also use SIK telemetry outdoor with OTG on my android phone (QGroundControl).

3DR 433 radio is connected via USB on the Pi4, I have a Benewake TFmini Plus range finder on the Navio2 UART.

GPS–Telemetry conflict: could be a RF problem, telemetry signal killing GPS signal. Move the antennas and check if there is any best.

Marc

Please let me know the link of your telemetry connection and GPS failures.

I’m experiencing this while connected via USB, as my telemetry port still does not work.

Vegeta

A post was split to a new topic: Telemetry configuration issue

I do not think assigning the same port C to different telemetry option is the good way.

Capture d’écran 2020-10-06 à 18.54.27

I’ve tried with only TELEM2(UART port), and still no heartbeat packets received.
The radios do flash red very briefly, then quit.

However when TELEM4(radio to USB on drone) is included, the connection goes through.
Major problem with USB connection, so far, is the velocity variance and GPS lock. Drone thinks its jumping around. I will provide video if needed.

I’ve updated to Arducopter 4.0 and no fix has been found.

Your /etc/default/arducopter file is to be redacted:

If you want to use USB telemetry radio or UART telemetry radio (or both?) and do not want to reconfigure before each flight, you need to assign different serial port for each option.

ref: https://docs.emlid.com/navio2/common/ardupilot/installation-and-running/#specifying-launching-options

Default is -C /dev/ttyAMAO (serial1-UART) or -C /dev/ttyUSB0 (serial1-USB)

Your possible arducopter TELEM option:

TELEM1 no change,
TELEM2="-C /dev/ttyAMA0" when SIK radio is connected to UART (serial1)
TELEM3="-D /dev/ttyUSB0" when SIK radio is connected to USB (serial2)

ttyS0 (I cannot say if it is a valid option?)