Tarot 3-Axis Gimbal with Navio2

I’d like to connect a Tarot T4-3D 3-Axis Gimbal to my Navio2, but I’m unclear on how to wire it up. Manual is linked here.

There is a PWM1(SBUS) connector with 3 wires, and a PWM2 connector with 1 wire.

In a post on DIY Drones a community describes the following setup on a Pixhawk:

  • set gimbal to pwm (not to sbus)
  • connect pwm1 from gimbal to rc9(pixhawk) AUX
  • connect pwm2 from gimbal to rc10(pixhawk) AUX
  • go to mission planner -> intial setup -> optional hardware -> camera gimbal
  • set TILT to RC9 and do not check stabilization and then set what channel you want from radio RC6, RC7
  • set PAN to RC10 and do not check stabilization and then set what channel do you want.

How would I approach a similar setup on a Navio2?

Just replace the word pixhawk with Navio in the diydrones post and you are good to go.
Why should the setup be different?

Any guidance on what I replace the words ‘rc9 AUX’ and ‘rc10 AUX’ with? Should I just treat these as Servo connectors?

Yes, just connect them to servo channels 9 and 10.

Thank you for the guidance, will test that out.

Can I suggest a section in the Navio Docs about different Gimbal hardware setups? There is the APM general documentation, but it is all pixhawk specific and does not cover 3-Axis Gimbals other than Storm32.

Take a look here @marstonstudio Strange motor reaction to using RC outputs 5-7 and other oddities

I ran into problems setting up my Feiyu 2axis gimbal also. And documented them here, It’s not very logical but i think you should be able to get it working if you read that post
You’ll have to use rc passthrough function on the RC_X channels you specify (RC_9, RC_8 etc) Pasthrough will mean RC_9 will passthrough your transmitters channel 9 signal.

Best of luck

Hey. Struggeling with the same gimbal.

Where in mission planner (1.3.48) with copter 3.4.6 can i find the “BRD_CAN_ENABLE” and “BRD_SBUS_OUT” assuming they excists for navio2? Atm i just see BRD_SERIAL_NUM in full parameter list.

what is the default output-signal for navio2 output 9-14 (pwm or sbus)? trying to use passthrough on channel 10.

There is no CANbus or SBUS output on the Navio. It basically just passes through what the Raspberry Pi offers with the exception of the RC coprocessor for sbus/ppm input and hardware PWM and also an ADC. Perhaps it will possible to add sbus output with a firmware update for the RC coprocessor. You will have to use PWM to control your gimbal.

ok, can’t get the gimbal moving with pwm (as i’ve read others also had problems with). I know the signal are passed through the navio since it activated some other servo i tested on it. The gimbal wont even work when i connect it directly into the FrSky X8R in mode 4.

I think there is a problem with the firmware version v1.1 on the tarot gimbal. I had tilt working before i updated, and now, with v1.1 nothing works in pwm mode^^

Excuse my noobness, but if I’m using my Reach as an aux GPS and it’s plugged into the UART port, where does the Gimbal plug into the Navio2?