Strange motor reaction to using RC outputs 5-7 and other oddities

I was planning to control my gimbal via arducopter. But when i assign rc5-7 to rcpass-through all the motors start stuttering back and forth.

But rc8 works fine and I can set it to start controlling either tilt or roll

But I can only assign roll and tilt (via MNT_RC_IN_TILT / ROLL) to RC5-8.Which only leaves me with one usable channel RC8

And… receiver channels 6-7 (I’ve 5 set to a logical switch so haven’t tried) also won’t map to RC8. I set the mapping on the gimbal setup page, (I don’t know what parameter maps rc channel to MNT_RC_IN_TILT /ROLL maybe that’ll help)

at the moment this is the situation, as far as i know:
https://docs.emlid.com/navio2/Navio-APM/ardupilot-tips/#auxiliary-function-switches

have you tried setting MNT_RC_IN (tilt, pan, roll to channel 7,8 (i belive you already set that up correctly) and set rc_out on higher channels (ch9-14) to roll tilt pan (it should be 6,7,8 for rc_out)? i believe that should work, theoretically…

No didn’t try that. I’ll give it a go and report back

Nope. RC5-7 cause motor stuttering. RC9-14 have no response (although ardu parameter description for MNT_RC_IN only gives 5,6,7,8 as options ) currently only RC8 works.

Gimbal control input and output does not have to be 1 to 1. You can use any free input channel to control a gimbal connected to RC 9-X. I remember some limitations in the Missionplanner gimbal setup GUI, but it should all be configurable in the full parameter list. I will have a look at my gimbal setup later and report back.

And that warning states that RC5-8 isn’t supported and could cause motor trouble. So I shouldn’t even be using RC8? Doesn’t seem like the Navio2 can’t support rc functions for a gimbal.

Do not confuse RC inputs and outputs. That warning only applies to RC output connectors on the Navio2 board.

sorry for being inprecise this is what i wanted to say:
set the values as following in full parameters list:
“rc9_function” to value “6” for PAN
"rc10_function" to value “7” for TILT
"rc11_function" to value “8” for ROLL
according to http://ardupilot.org/copter/docs/parameters.html
and keep your MNT_RC_IN values

No I don’t want the Navio to process the signal just to pass it through directly. Hence setting it to 1. Seeing those values had no effect on my gimbal.

so you actually want to control your gimbal only via remote control;
then just ignore the mnt_rc_in settings;
set up channels 9-11 accordingly on your remote control and use passthrough option in missionplanner;

what gimbal controller board are you using?

So how so I map a transmitter channel to an RC out without using mnt? Using an off shelf feiyu 2 axis.

what rc transmitter and receiver are u using?
isn’t it possible to assign the rc channels to your transmitter? (if you want to use the passthrough option mnt isn’t helpful)

Hi,
Sure I’m aware of the possible mix up but I’m not making it. Yes I’m looking for that parameter that maps rc in to rc out but at the moment I only know of the convoluted mnt option that works with a roll tilt tag via the gimbal setup page and mnt.

How do I to use passthrough without using MNT_ or the Gimbal screen? I’m not aware of a way to assign Navio rc outputs to my tx without using MNT.

This post I found does a great in depth analysis of the passthrough and rc out, really worth a read.
http://www.rcgroups.com/forums/showthread.php?t=2333925

notes:
passthrough passes rc in through to the same output channel so rc6 in will go to rc6 out.
MNT and the gimbal page will allow you to map different rc in to different rc out (This is the only way to map channels so looks like only 3 possible)
BRD_PWM_COUNT toggles which rc-outs can be used for pwm (rc9-12 only 4 by default, toggle to allow up to 14)
I’m not in a place to try any of this right now but clears a few things up.

I wasn’t getting those RC-9 to 14 results because my Taranis was set to only use 8 channels. :scream: Now very simple using pass through on those channels.

One more question, I made a little trigger for my camera out of a cheap little bluetooth camera trigger for my souped up Xiaomi Yi (great little camera to hack and up bitrates, resolutions and more). basically a small circuit that replaces the pushbutton with a solid state relay that’s controlled by a 5v trigger. Which I’d though would be a spare rc out RC_12. But I’m not getting anything. I don’t really know what comes out of an RC. So how do I get a 5v circuit from an RC out. What pins should I be connected to?

Thanks in advance

good to hear rcpassthrough works now;

rc pins outputs: ground, 5v and a PWM signal usually (but you can alter that PWM signal);
it should be possible to set it up as on off (never tried):

rc_12function should be value “10” (camera trigger)
CAM_TRIGG_TYPE to “1” to act as a relay

hope that works!

Hmm sadly not

Here’s what I’ve done and tested with my multimeter
rc_12_FUNCTION "10"
CAM_TRIGGER_TYPE "1"
CH12_OPT “9” (camera trigger)

That changes the normal 5.3v positive pin to 3.85v and changes the signal from 0v to 1.45v but hitting my trigger does nothing to change those static values.
I tried RC_12 “1” RCPASSTHROUGH and It goes from 1.4v to 2.65v upon activating the switch I guess I could jig around my resistors and get that working but I need the FC to auto trigger at waypoints.

So I’ve set up the channels correctly but not managing to get this relay function to respond, any parameters I’m missing?

I’ve also tried adjusting the RELAY_PIN parameter to “50” which allows pixhawk AUX1 (Navio RC_9) to function as a relay, but still no dice. Anyone managed to get relay output?