Strange result in rtkplot with coordinates to waypoint

Point 6 is supposed to be more south then this.
Tried different online map services and they all show correct location of point 6, but not in rtkplot.

When i plot the same coordinates into a different mapservice like this
Point 6 is more south and correct placed and everything lines up great.

Any idee?

Please explain what you mean by more south:

  • Is the numeric coordinate for point 6 incorrect?
  • Is the vertical grid distance incorrect?
  • Does the visual distance in rtkplot.exe look incorrect?

Point 6 should be south of point 5. And by the look of the north value of point 6, it show a lower value then 5…
Both numeric values in the pictures are correct but is displayed wrong.
The grid is correct
The visual distance is also correct but, point 6 as statet above is in fact south of point 5.

Edit: it is only the latitude direction of point 6 that is wrong.

Which hemisphere are you in? North or South?


Well you’ve got me scratching my head now too. Why don’t you add another point manually and see if it comes out in the wrong direction as well?

Added point 7 with the same latitude as point 5 and a bit west.
Point 7 appers not to be at same latitude dispite the same lat. value… Strange

Edit: east to west

Well, I think you’ve got Gremlins™ then.

And I really hope rtkplot.exe doesn’t have a randomize_points_to_mess_with_user() function :wink:

Can you post the source file. Maybe there’s some weird characters in there?

1 Like

Well…then theres another problem. Save doesnt seem to work in rtkplot. Can`t save waypoints.
Gonna try another rtklib first.

1 Like

If you hover over the screen with your cursor, it should tell you the cursor coordinate location in the status bar at the bottom of the window.

No info there.
I didn`t run or load any data into rtkplot, just open empty rtkplot, open waypoints and manually enter coordinates.
That should work ok?

Same result with other versions. 2.4.1 and 2.4.2

One more thing. I see i wrote importet coordinates in the heading, but this is not intirely true.
I manually entered in points under waypoints in the menu. Could this be it?
Does anybody get the same result if they do the same thing?

I only spend a minute trying, but with RTKLIB 2.4.2 patch 11, could enter the waypoints manually, but I couldn’t get anything to display on the grid.

I can confirm - it looks like it is shown 180 degree turned by rtkplot

Point 5 is the upper right point on the google maps card

bilder kostenlos

1 Like

Did you enable "show map point/waypoint"
It`s in the upper panel next to map image button

Can you save those waypoint as well?
And reopen it from a new empty rtkplot?


Sorry to revitalise an old thread, but the ‘latest’ version 2.4.3 b33 of RTKplot suffers the same issue

It appears every version of RTKlib suite has different issues mainly in RTKplot

I think its always been there. Have seen it ocaacionally in later versions too.
I am under the impression it only happens if you open RTKplot and work with waypoints only (or at least start of with waypoint/add waypoints manually.
If you open RTKplot from a processed file (RTKpost) , it doesnt happen as i can recall

I can’t confirm that as I haven’t tested it yet, but I can confirm the Emlid branded version b33 of RTKplot has the issue whereas the same version from here of b33 doesn’t - both used independently of RTKpost, very strange.