Stand alone Reach - RFD900 Config


I’m trying to set my Reach up without going through the Pixhawk. I can’t figure out how to configure it for use with RFD900 radios. I just want to send my Reach for a ride on my UAV. It does not need to navigate.



You didn’t really ask a question there. What are the methods that you tried? Maybe we can spot the problem.

Trying to setup a pair of Reach units, rover and base, to communicate via RFD 900’s. We connect the 900’s to each reach using both UART and USB with no luck. I see on other post that in the Reach View App there is a drop down for USB or UART when connected correctly. When are are using the app these do not show up. Im not sure if neither are being recognized or just have the wrong settings. It sounds like another user by the name of jmcarthur was having similar issues and you helped him through it. The main thing I guess is making sure we have everything wired correctly and that our settings in the View App are correct.

P.S. I am working with the gentlemen that asked the question above.

Did not realize you were able to update the Reach via the View App.
Below are the Reach View App Settings after updating both devices to v0.4.6

Base Station Settings:

Rover Settings:

The coordinates are taken out to at least 5 decimal places but not shown for privacy.
We seem to have a problem with connecting the base and receiver using the RFD900+.

Picture of both Base and Rover setup:

Our goal is to set this up on an UAV independent from the aircraft navigation to see what kind of data we can collect.

Any and all help is appreciated.


Wiring is good.
Settings for RFD900 are good.

Are you getting the proper blink sequence as shown in the docs? Or is it just a 2-colour magenta/blue flash?

Sorry for the slow response. We finally go the correct setup going with the radios talking. When the radios are communicating correctly they have a solid green led on the 900 I believe. What I was doing wrong was walking out of connection of wifi with the rover instead of the base. I didn’t even take into consideration that the base station shows nothing on the Reach View App but the rover does. When I have some time I will post a complete setup of the process from scratch to help others from out of the box to running with RFD900+ radios.

Our next step is to get a camera trigger event with the data from the reach itself.

Thanks for the help. You helps us a lot on getting to the right track.