Solved: Some motors not spinning upon arming

TL;DR > Re-calibrate your ESCs.

I recently followed this thread to upgrade to ArduCopter-3.5 but struck some problems after the upgrade. I think I’ve solved them now but thought I would post here to save others some time in case they encountered similar behaviour.

After the upgrade, when I armed the quad motor 1 (front-right) wouldn’t spin at all, and motor 3 (front-left) spun at about half the speed of the two rear motors. Looking at the servo output in the tlog from apm_planner show the output was much lower on the two front motors, with output 1 being the lowest.

Once armed and with some elevator applied, the two front motors came up to full speed, in fact even faster than the back props, so much so that it looked like it was going to flip backwards. Being slightly more aggressive with the elevator and it got airborne but pitch and roll seemed to wobble around more than it had previously. Looking at the servo output in the tlog showed servo output 1 to be fluctuating quite a bit compared to other outputs.

I re-installed the previous 20170323 Jessie image and went through basic configuration but still had the same problem. Hunting around the ardupilot forums I came across a few mentions of re-calibrating your ESCs. It didn’t seem like the intuitive solution as the servo outputs from the Navio2 were quite different for each channel. I followed the steps mentioned in one of the Ardupilot tutorials. The LED patterns are a little different and my Afro 30A race ESCs didn’t emit the tones mentioned but it appeared to work and on raising the elevator all four motors spun up at similar speed. The output in the tlog looks much better too. It’s a too windy to fly right now but will be interesting to see if it takes off and flies more stable.

1 Like

I finally got a chance to do some test flights last weekend, and after calibrating the ESCs all props now spin up evenly when armed, and the quad also seems a lot steadier in the air :slight_smile: Next step is getting camera triggering working in auto mode.


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.