[SOLVED] Reset Reach wifi configuration

During an attempt to setup the wifi on one of the reach units, it seems to have gotten into a state where it a) doesn’t connect to the wifi network that I specified, and b) doesn’t broadcast the reach:mac hotspot to reconfigure. Is there a way to reset the settings on the reach to attempt wifi configuration again? When powered, the led blinks white, blue, blue, red.

Nic, are you sure that it is not connecting to your Wi-Fi network? Have you checked it with nmap or fing? It is possible that it will not respond to reach.lan in some network configurations, but should be available by IP.

Yes, I can confirm that the units do not attach to the network. They do not appear in the router client list, nor does nmap provide any connection information. The very first time the device was was configured, it did attach to the network and establish an ip, but connecting to the ip directly in a browser did not show the ReachView app. The next power cycle, the unit never attached to the network again, and now it just cycles the white, blue, blue, red leds repeating when powered.

Is there any way to connect to the device via the USB to configure it? Or can I reflash the firmware to reset it? (the firmware download link in the docs is missing).

We will update the docs with image download link soon and also with instructions on how to establish network connection over USB.

Meanwhile, maybe you can try to get out of the range of your home Wi-Fi (or turn it off for a minute), so that Reach does not see it on power up? That should make it switch to access point mode.

I am having the same issue. After connecting to reach via the Reach hot spot and switching over to the Wifi network, Reach could not see http://reach.local, When rebooted I am see the led blinks white, blue, blue, red. Will try rebooting without the Wifi network active as suggested.

I booted with the wifi network off, and Reach switched into access point mode and created it’s own hotspot. I went through the steps per the documentation for the next steps. Reach was able to connect to the wifi network but could not access device via http://reach.local. I ran fing on my android, and it sees the Reach at
I tried and on chrome and got “This webpage is not available”. Also tried accessing it on a Windows machine on the same network and got the same error. Will wait for further instructions from EMLID via this forum on how to troubleshoot.


We’ve updated the docs with a working image link and a guide on how to connect over USB Ethernet(in Software Development -> Connecting to Reach via ssh section).

Concerning the LED statuses. ATM they are a little bit hard to read and we’ll address that later. The important thing is that the white light is the sync signal, marking the beginning of status message. The next light shows if Wi-Fi is in AP mode(green) or client mode(blue).

Nic, there are a couple of things we need to clear:

  1. What happens after a power cycle? By default, it is supposed to try and connect to any known networks. If the device can’t find any, it will create an AP. So, if after reboot the hotspot is not created, then Reach connects to your network and does not receive an IP address. I know this is a long shot, but you can try rebooting your router. I have actually been in a situation like this once, when the devices were connected, but did not show up during scans and it helped.
  2. Try connecting via USB Ethernet. Use ifconfig to see what is going on
  3. Try connecting Reach to an alternative network, like a smartphone hotspot. To boot into AP mode, you will need to power Reach with your configured network off or out of range.

Gabriel, your case seems to be better than Nic’s as the device shows up on the network. If the LED blinks, then the App is running, so it should be accessible. What happens after rebooting Reach? Try to ssh into it, to see if it’s available for connections. You can also try to connect it to a smartphone hotspot.

I was able to get one of the reach devices to appear using a different router. When the original network was removed from the area, the reach went back into AP mode (solid green LED) and I was able to reconnect, setup the new network, get it to bind to the new network and access the ReachView app (and ssh into the device). My new issue is that the start/stop buttons don’t seem to do anything when pressed in the ReachView app. Having a new issue now, but I’ll open another thread since it’s unrelated to network.

However, I was only able to do this with one of the devices. The second device boots in AP mode (solid green LED), but the AP never actually shows up for connection.

I am going to try to connect to the second device with a USB/ethernet adapter. Will report back shortly.


Can you also please post details about your network gear and setup? We are trying to track down the issue but can’t reproduce it with any of the equipment that we have. We have tried Android hotspot, IPhone hotspot, Tp-Link routers and it all works for us. Anything you share can help us with debugging. Thanks!

I have nearly the same situation, except for a slight difference. If the WiFi network is absolutely not available (as in the WiFi router/AP is turned off), the REACH does not make its own AP available. It tenaciously remembers the WiFi network it was configured to, even after several reboots.

I guess this is good and bad. I do want the WiFi to be “sticky” because it is so much trouble to correct in the field. But at the same time, it does mean that if the WiFi network is turned off or out of range, I can’t reconfigure the REACH.

In our case, the WiFi router/AP is actually a Samsung Galaxy S5 configured in mobile hotspot mode. An additional symptom of interest is that if the Galaxy S5 doesn’t have access to the internet via cellular data, the REACH will not connect to its mobile hotspot properly. I am not sure why this is, as other devices like laptops can connect to the Galaxy S5’s mobile hotspot just fine. Once I remedied the cellular data issue, the REACH module did join the Galaxy S5’s WiFi and became available finally.

I am on REACH 1.2 at this time. Both of the units I have behave like this so far.

To add a possible finding:

Because one of my two smartphone WiFi mobile hotspots was simply missing, what I did was to set up a spare home/desktop WiFi router with the same SSID and password as the REACH module was expecting.

And interestingly, it did not work completely. What happened was that the REACH would show up in the DHCP listing on the desktop WiFi router, but it was completely unreachable. I played around with the security settings and found that WPA2-PSK-only at least got me to the point where the REACH was pingable, but it was never actually reachable on port 80 or 5000.

What I did was take the one smartphone I had on hand and change its mobile hotspot setting to fake the SSID and password, and THEN, I could fully access the REACH module.

Why is this the case? Could it be that the desktop router I was using was blocking something? I doubt it, as it was a very dumb router, and LAN-to-LAN traffic would not have been blocked.

I wonder if the REACH’s WiFi connection remembers or retains extra info about the WiFi router such as MAC address or something like that. One thing I did notice was that the desktop router used 192.168.2.xxx and the smartphones both used 192.168.43.xxx.

Anyway, it was an unexpected behavior with the WiFi that should not have happened and may need to be addressed by EMLID.

That should not be the case. What LED sequence do you observe?

The symptoms that you are describing are very strange. Can you try reflashing your unit? Do you have only one or two units? Do they both behave in the same way?

Yes, it is very strange behavior. The LED sequence I see when the WiFi router is missing (smartphone with mobile hotspot many miles out of range) is:

Blue Magenta Off White Flashing Yellow Green Repeat

This loops over and over and the REACH never produces its own WiFi AP.

I have two units both ordered at the same time (same hardware revision, whatever that is). They are running REACH v.1.2 (and were updated exactly once from whatever version was on the units when they shipped, which I believe was 1.0.1 or something like that). Yes, they both behave the same way (successfully connect to the one remembered external WiFi network if that network is available, but refuse to connect to anything else and refuse to create REACH WiFi AP otherwise).

I do not own a USB Ethernet adapter yet, so I have not tried reflashing.

I will check to see if they remember my home WiFi router for some reason (what they were updated with) per this thread: Resetting WiFi, but my home WiFi router does not list them as being DHCP clients.


It turns out that yes, the REACH units were finding my home WiFi router when they could not find the smartphone WiFi mobile hotspot. For whatever reason they were taking a long time to show up in the home WiFi router’s DHCP client list.

All of you can disregard my messages in this thread except perhaps as a cautionary tale. Sorry for the trouble!


Been trying to reboot reach. And not sure if its doing so.
If it is how long would it take?

Hy all

sorry but I have a big problem …
I deleted (mistake) the wifi config and now I’m not able to use my device
I tried to reflash several time but without any result
… please help …



Reach is using its own hotspot. Log on to that and add wifi. No need for reflashing.

1 Like

thx for answer …but if I add the wifi I’m not able to the next step

any idea ?


Can you post a screenshot of this next step, please?


… after several reboot, plug unplug, wifi on/off … now it works

thx for support


1 Like