Smart phone cannot find Reach RS3 WiFi

trying to set up RS3, but with no success. As I turn on the receiver, I get the solid Wi-Fi LED symbol lit up, but no Reach Wi-Fi network appears on my phone. After a while, the connection LED started to blink, but still no Reach Wi-Fi network on my cell. I tried to switch the WiFi on and off, reset the mobile phone, switch on and off the receiver, but no avail, the problem persists. Please, advise on how to resolve the problem. Attached are the pictures showing the situation.

In case you are creating a thread about an issue, please specify the appropriate sub-category first!

The wifi icon being BLUE indicates that the receiver is “connecting to” some wifi and is not presenting it’s own. If the receiver starts up and cannot find a network it has been told to look for, then it will switch to host mode and present it’s wifi and the icon will be WHITE.

Since a wifi network has to be added to a receiver for it to be found, you or someone else, has to have added a wifi network that that receiver is finding upon startup. If you don’t have any idea what network it is finding, then you need to move the receiver far enough away from that network and start it up. It will then present it’s own network which you could then find on your phone.


Thank you.
There was only one network to which it must have been connected, and that’s the same one to which my phone was connected (the only one that does not require a password). But then I should see the RS3 on the Emlid Flow, right? But I couldn’t … Any ideas why?

I have had this with the RS2+ previously. And it caused me some headaches trying to sort it out.

I am pretty sure it is something to do with my phone wifi hotspot. I had no issues with the tablet wifi only on the phone. This was bad, as I couldn’t reconnect to stop log files. No way of connecting in at all, which sounds pretty similar to you, it started up full blue lights and then went to flashing blue and no sign of any networks from the RS2+. I would suggest tryng with another device, but after wiping the wifi networks from the RS3. So take it out of wifi range / turn the main network off for a while. Then when connected into the RS3 through its wifi (white lights), go into the settings and find the networks page. Delete / forget the networks there. It should then start up in white light mode every time.

I have stopped using the common hotspot approach (blue light). I will have another go when the phone gets upgraded or using the tablet in future but for now I’m not happy with the chances of a failure so best to avoid. I have added sims to both RS2+ so now can use them over ntrip and they have data to perform updates etc.

My ticket with support found that it will likely be the device you are using for the hotspot. Although if that is a house / office wifi it may be something else. Support had not experienced this before so beyond the try another bit of tech for controller there wasn’t much they could do.

Hope it helps

1 Like

Sometimes the WiFi access points and network routers don’t allow network clients to see each other unless explicitly allowed - there’s often a setting on the AP/router called something like 'wireless isolation" or “allow network devices to communicate with each other”. Some switched corporate networks also don’t always work well as they use virtual networks, and those often need particular settings made before the inter device routing works properly.

Best thing to do is, as mentioned above, take the Reach unit for a walk or drive to get it away from any known networks, then turn it on, connect your phone to it using it’s own internal wifi hotspot, and then get the reach unit to forget any known networks. Once you’ve done that, you should then be able to set it up with your phone’s hotspot details and restart & connect up that way.

Good luck


Thank you @scottmitchell63 and @ElectroNick . All that you are saying makes perfect sense and resonates with the problem I’ve been experiencing.

I managed then to make the updates with the hotspot, although it was a bit tricky (The problem with using the phone’s hotspot to launch the RS3 is that the Updater asks you to select your phone’s WiFi (hotspot) from the list of available WiFis, which is of course not there as only “external” WiFis are shown. If I close the Updater, I was back to where I had been before … Refreshing the list of connected devices in Emlid Flow solved the problem then).

Thank you all for the invaluable help! Hope this is the last complication of the kind. Such things are so frustrating …

I seem to recall something similar when I first setup my RS3 - it took several frustrating hours of setting/resetting and connecting the RS3’s wifi to various networks before everything eventually ‘aligned’. It wasn’t the smoothest procedure & I seem to remember a few choice words being used too :face_with_spiral_eyes:

Hi @SurveyingBird,

It’s unfortunate that you couldn’t connect to your Reach device on the first try. I’m glad to hear you were able to do it eventually with the help of Scott and Nick. We’re thinking about how we can improve this process for our users.

We have an alternative Bluetooth connection in the Beta version. Although you won’t be able to update the device, you can use it to set up the device and collect points. To activate it on Android devices, you can follow the steps from this post.

1 Like

@ElectroNick Yea, same here. Even with the just-learnt hotspot trick it took me a while to start the second receiver. The activation process kept being in a loop. Not even sure how I made it work in the end.

@olesia.riman Thank you for the tip. Bluetooth might work better as you don’t lose data connection and can still use the internet.
The post you linked doesn’t say if the feature is available for RS3 in Emlid Flow or instructions how to activate the BLE there. Any updated instructions somewhere?

This feature is available on the RS3. On an Android device, you need to turn on the BLE toggle in the internal settings. To find that switch, tap on the profile icon in the bottom right corner really fast about 10 times (until the menu appears) and turn on this option. After you activate the BLE switch, reopen the Emlid Flow application and give the app location permissions on Android. You should see two connections (Wi-Fi and Bluetooth) after that.

1 Like