Short circuit on M2 GNSS Antenna

Greetings. I accidentally short-circuited my GNSS antenna when I connect it to my Reach M2. I used a new mcx plug and initially I didn’t recognize that there is a defect on it, that leads it to short-circuit.

Now I can’t see the satellite signal received to my M2. I checked the MCX female plug on the M2 and it seems to be okay (3V of power). However I can’t confirm my GNSS antenna health.

Is there anything I can do to fix it?

Hi @surveinusantara,

Is there any chance that you have a second Reach M2 unit? If so, please check if the second unit behaves the same way with this GNSS antenna. It can prove that the antenna is indeed broken.

Another quick question,

Is there any issue with powering up the M2 with the antenna disconnected?

I don’t know why you would do that, M2 has to have time input from sats to do anything on the app from my experience using for static.

Like if you are updating firmware, it would be powered up but you might not plug in the antenna while doing that.

2 Likes

Hi @kseniia.koliuk ,

I have a similar GNSS antenna. However I am in a remote area now, and I will be able to check at next Thursday. I will inform you once I try to use it.

By the way, how much the voltage of GNSS antenna plug for a normal M2? Mine is 3.2V, and I have no idea whether it is good or bad.

I haven’t updated yet to last firmware, but I believe you still have to hook up antenna

Hi @surveinusantara,

Reach M2 can supply up to 3.3V of voltage to the antenna. So, the voltage is within normal limits.

@kseniia.koliuk

Is there any harm if M2 is powered up without antenna?

Ive done it, it still works, just wondering if it could harm it

1 Like

I have tried another antenna. Unfortunately, the satellite signals still not appear received on my Reach M2. So I think the problem is not on the antenna.

Actually, I have two Reach M2 units. They just arrived 3 weeks ago, and sadly I have never even flown them once. The disaster come when I connect them to a defect MCX plug. Do you have any solution for this, @kseniia.koliuk?

Hi @surveinusantara,

It seems that the units are indeed damaged by a short circuit on the antenna. Unfortunately, we can hardly be of help in this case.

Hi @PotatoFarmer,

Reach M2 can be powered fine without an antenna attached.

Thank you, one of my most burning questions about the M2!

Now just waiting for my RS2 to Arrive :blush::blush::blush::blush::blush::blush::blush::blush::blush::blush::blush::blush::blush::blush::blush::blush::blush:

Cant wait!

1 Like

Hi @kseniia.koliuk,

I simply can’t believe a chip that costs hundreds of dollars could be broken easily in that way ). Then I do a simple internet research about Ublox ZED F9P module that installed in the Reach M2. I think I found a hint to my problem in the ZED F9P Integration Manual document (https://www.u-blox.com/en/docs/UBX-18010802).

Referring to section 3.8.2 Antenna short detection - ANT_SHORT_N, it is mentioned that the short antenna will keep being reported as shorted unless the antenna short detection auto recovery is enabled.

I think it is definitely what is being happened to my Reach M2 receivers. The antenna status keeps reported as shorted in the Ublox module, so it won’t receive any GPS signals although the short antenna has been fixed. The antenna short detection auto recovery must be enabled in Ublox configuration, so the Ublox module could receive the satellite signals back.

Please kindly check the document and do improvement regarding this issue in the next firmware update. Maybe this incidence would be happened to other Emlid customers too in the future.

Thanks for your help. These Reach M2s worth a month salary of mine ))

Hi @surveinusantara,

Please check your PM. I’ve written to you there.

Hi,
can I update the M2 firmware without the antenna attached?

Yes read above, scroll up.

I asked if it is safe to update the M2 without the antenna attached.
Above they answered that M2 can be powered up without the antenna attached.
These are different things.