Servo control, Navio2 with FrSky X8R receiver and QX7 tx

Hi,

I am trying to control a servo using SBUS from the x8r receiver. It gives 4.6V, enough to power the servo. However when i try to control the servo through any channel 1-8 it does not move.

I have seen countless videos where people simply hook up the x8r receiver SBUS 3 pins to a servo, send input to that channel and it moves.

I have control on the channel from X7 since I can see the radio calibration on mission planner.

Any ideas?

Hi,

I am having several issues with the Navio 2 GPS:

  • EKF no connection
  • Unhealthy AHRS
  • Pos vert variance
  • Bad Gyro health

I don’t know the fixes to these. Any ideas?

Hi @harryhancock,

You need to supply voltage in the range of 4.8 to 5.3 V to the servo rail. 4.6 V might not be sufficient for servos to work while connected to servo rail.

Have you placed Navio2 with its antenna outside while testing it? The antenna should be provided with a clear sky view to receive the signals from the satellites.

Please also make sure to go through all the necessary calibrations. I’d suggest taking a look at the Mandatory Hardware Configuration guide that describes the calibration process in detail.

Dear Liudmila,

Thanks for your help.

Servos

  • should we connect the servos to the power rail instead of the sbus connection on FrSky x8r receiver? If so how can we control the servo through manual rc input such as flicking switch on the FrSky x7 taranis rc ?

GPS

  • Tried outside but not receiving anything, used to work indoors anyway. Also tried recalibrating.
  • I heard that GPS connection on navio2 board can burn out if the gps module not always connected while navio2 is powered on. Could this be the issue?

Latest raspbian image

  • Is there an issue with it since I had to flash new SD card, when i run ardupilot on navio2 rcio asks for update, i update and reboot but then it keeps asking for update with no end
  • How can i fix this RCIO issue?

ESCs

  • I’m currently using the Turnigy MultiStar 20A BLHeli-S Rev16 V3 ESC 2~4S
  • The navio2 no longer calibrates the ESCs, i use mission planner calibration and they beep out of sequence, completely different to before
  • I had motors throttle with full manual control but this issue randomly appeared
  • Upon reboot of navio2 in esc calibration mode, it lags and takes 5 mins to reboot the navio2. Any ideas?

Benewake TF02 Lidar problem with Navio2:
• Lidar wont connect when plugging in UART whilst navio is on, no data on mission planner
• used shutdown command on navio, then plugged in lidar, this triggered the navio to start up again, ESCs still beeping randomly, now lidar works?
• Fix: plug in lidar when pi is turned off following shutdown command
• Issues: Why did it restart navio and why did the lidar work?

Fixed RCIO issue, have to make sure the GPIO pins are the same size as ones provided in the box

Hi @harryhancock,

Thanks for the detailed description!

Please use the servo rail to connect your servos to the Navio2. To provide power to servos connect BEC to the servo rail. The hardware setup is described in our docs.

Please note that we don’t suggest connection servos to the RC receiver. Servos can consume a lot of power which the RC receiver port may not be able to provide. That may lead to Raspberry Pi and Navio shutting down and even getting damaged.

Could you please specify whether you’re using the external GPS module?

I can see that you started another thread in regard to the ESC calibration issue. Let’s continue our conversation there as to not double the information.

In regard to the Lidar issue, it’s very hard to pinpoint now what could be the cause of it. It’s important to always reboot the ArduPilot’s settings after applying changes. This usually doesn’t require the reboot of the the Navio2 system but it can be done with it as well.