RTKLIB two RTK reference stations (testing)

I have been experimenting with RTKLIB using two RTK reference stations (euref here in the UK) as rover and base. I can’t seem to get a FIX what ever I try just stays FLOAT, I now come to the conclusion this won’t work but I don’t know why - any ideas ?

The two stations are less than 200 Km apart.


What is your baseline ?

Hello, wisprod It’s about ~83.5 Km SHOE00GBR (Shoeburyness, United Kingdom) and HERT00GBR (Hailsham, United Kingdom)


Don’t expect a Fix unless you have some serious nice, unobstructed skyview up on a hill or similar.
Also, you have to add around 1 mm pr km baseline of inaccuracy, so you get an additional 8-9 cm’s.

I have done experiments with EUREF Ntrip with baselines up to 150 km, and only in very good conditions I can get a fix, and that fix might not even be very precise.

I guess there’s a reason the pro’s say to keep the baseline under 10 km :smiley:

I am only using EUREF ntrip to get me a float Base average quicker than I can get with Single solution, then I use my own base from there on.

What I’m doing is using two reference stations one set set as base and the other a ‘rover’ (even though it’s a fixed reference), so I assume they both will have good views of the sky seems odd I can’t get FIX.


I misread your first post :smiley:

Can your post your RTKpost settings (screenshot)?

Yes, but I’ve tried virtually every setting possible so now it’s probably totally messed up now. I might reload RTKLIB to get back to the default settings - unless someone has a copy.

Just remove the .ini file in the program directory, and it is back to square one.

Ah thanks for that - good tip !

Here’s my settings BTW



The settings above are now working with an intermittent FIX albeit with a lot of wandering over 10 minutes, but I guess that’s down to the 83 km baseline !

What happens if you try with default settings (but change Position mode to Static, Elevation mask to 20, SNR mask to 35, enable all systems, and change AR filter to On) ?

It doesn’t seem to FIX at all, I’m I sure what you mean by enable all systems other than that I tried what you said. It’s interesting to see how using two reference stations to identify where errors creep in.

What version of RTKlib are you? I just noticed that it doesn’t look like mine from here: Kinematic processing | Emlid Studio

version 2.4.3 demo5 b29d from GitHub - tomojitakasu/RTKLIB at rtklib_2.4.3 if I remember correctly. I’ve fiddled some more and it seems to lock within seconds

UPDATE: It was from here http://rtkexplorer.com/downloads/rtklib-code/ - Sorry

For such long baselines, set Min Ratio to Fix Ambiguity to 1 instead of 3.

Never set the ratio to anything below 3. The data is much less trust worthy in that case.

That is true. But for long base lines, already there exist too huge errors that will compromise solution anyway.

Not really, I have gotten down to 1 digit cm level using EUREF station-to-station experiments using L1 only. And some of that (milimeters) could even be down to tectonic movement of the station location over time (as many of the measurements provided for the stations are a little old).

I’ve been doing some more testing and it appears that when I disconnect and reconnect from to two fixed reference stations 21836.3M apart the Fixed position is aways different (which I would expect) however, the fixes are quite a bit different any ideas why this is ?
I marked each FIX with waypoint.