RTKLib Base coordinate differences between versions

HI all

This has been driving me crazy!

In comparing the differences between the old RTKLib(RTKPOST ver.2.4.3 Emlid b27) and the new 64bit one(RTKPOST ver.2.4.3 Emlid b28) I see that dispite the same parameters being used for each, the coordinate mysteriously changes in the 64bit version. Any one seen this? the INI files are identical.

64bit version
64bit Version

Old version


Do you get same result if you delete config for both version before your run RTKpost?

Ja, same result! Truely strange

Here are the ini files. The ref lines are the same.ini.zip (2.8 KB)

Tried with a set of files from this forum but could not reproduce your difference in ref. pos

I also notice my text view (b28) looks different then yours…
Edit: I used Rinex header, not manual input

Nope, still works like a sharm here.

I could be ‘out to lunch’ here, but were people not complaining about that ref pos field not being reported properly and something was going to be changed to fix it? Maybe this is the change?!? :thinking:

Ja, any job that I process is giving different base coordinates. I wonder if is a “Southern” thing?!

The file i used is from the same area i think. Lukeland :laughing:

I have got the same problem using 64bit rtkpost 2.4.3 Emlid b28.
It seems to me that the 64bit version doesn’t use the “Lat/Lon/Height” information from “Settings/Position/Base Station” and rather takes the “Approx. Position XYZ” of the base RINEX file instead.

I did a test survey lately and used a VRS to setup a Reach as a base. Then surveyed some points with my 2nd Reach with live-correction from the Base-Reach. I also surveyed the same points using VRS. The measurements are within about 3 centimeters.
Afterwards I did a PPK and all my PPK positions differ from the RTK ones.
I found out the Base-Station Position in the PPK solution file didn’t match the VRS surveyed base coordinates. So I compared the “Approx. Position XYZ” of the base RINEX file with the “ref position” of the PPK solution file and they matched.

1 Like

Shew, I thought I was going crazy! Im glad (not really, sorry for your woes!) that this can be replicated by someone else.

1 Like

Just did another PPK run where I changed the “Approx Position XYZ” of the base RINEX to the VRS surveyed coordinates and the solution is spot on with the base-rover and VRS survey.
But I was still using “Lat/Lon/Height” as selected option in “Settings/Positions/Base Station” … didn’t change anything there.
So rtkpost 2.4.3 Emlid b28 aint using the “Lat/Lon/Height” information … it’s using the “Approx Position XYZ” of the base RINEX instead, while “Lat/Lon/Height” is selected in the rtkpost options.

And about that “Southern thing” … I am from Austria :wink:


Thanks for looking into this for us! I’ll make sure this is fixed.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.