RS2+ WiFi connections issues with iphone

Dear Support,

no problem with WiFi connection with android. Other story with iphones!
Big issues when establishing a wiFi connection with RS2+. Mostly it is not possible and if possible, there are dropouts. At the moment not possible to wotk with iPhones.
Could you please advise how to fix it?

Hi Alex, just to note - I am another user, just like you.

Anyway, I also use an iPhone (13 Pro Max and also an older iPhone XR) and it is quite stable in it’s connection to Reach RS2/2+ devices.

I wonder - have you been able to update both the Flow app, and the firmware for your reach device? Perhaps that is worth a try if you have not already done so? Also if you are running a very much older iPhone (iphone 8 or less) perhaps then the iOS version isn’t as helpful for a stable connection.

I can’t really provide you a clear fix, but hopefully these pointers and the reassurance that I can’t replicate your problem with my devices running latest stable channel firmware (ie. not Beta versions) and latest Flow app versions.

Hope this helps?

Regards, Al.


Hi, @KalmarSystems!

I agree with @flow point. Please ensure you’re using the latest Reach Firmware and Emlid Flow application.

Does the issue persist with a particular network only? Have you tried connecting the unit to other Wi-Fi networks? Does it work fine when you connect to the receiver’s hotspot?

We also have a post with tips on how to connect to Reach RS2+.

many thanks for the support - will come back soon after testing.

1 Like

indeed, there was only a Fw update needed…now it works… oh man.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.