RS2/ReachView Survey Project Export issue on iOS

I have an issue exporting a survey project .csv file. The issue happens with several projects which I’m making changes to, and have previously exported. After making changes (adding a point or deleting a point in the ReachView app), the subsequent export does not reflect the changes. Although in the ReachView app I can see the changes made, the export file I’m getting looks like the previous export and does not reflect those recent changes.

I’ve tried:

  • deleting previous exports from the iPhone/iPad
  • restarting the reachview app
  • restarting the RS2
  • not saving to the iPhone/iPad, but rather airdropping to my MacBook

I’m using:

  • ReachView v2.22.4
  • iOS 13.5 (iPhone and iPad)
  • EMLID Reach RS2 (how do I find firmware version?)
  • system report available, not sure how to include it here…

My suspicions as to the problem:

  • iOS is not deleting the old exported files, and is not overwriting them when exported from ReachView with the same file name, so I’m seeing old cached files
  • ReachView app is not exporting current saved data

Update:

  • I’ve experienced the issue a few times, and I believe a few times have found that after the RS2 unit sits powered off for a little while, overnight for instance, and the export is tried again subsequently, it then does export the correct data… Is there a certain amount of time it takes for the RS2 once powered off to purge cached data or save current projects?

¯_(ツ)_/¯

Hi Josh,

Sorry for the delayed response!

Thanks for the detailed summary. Would it be possible to attach the screen-recording of the issue? You can upload it on any of the file exchangers like WeTransfer or Google Drive and post the link here.

Please share the Full System Report with me in PM as it may contain sensitive information. You can upload the Full System Report in the same way.

Thank you Polina,

How do I pm you the information?

Hi Josh,

I’ve just sent you a private message. You can answer on it by sharing the report and video recording with me.

Meanwhile, we’re trying to reproduce the issue. I’ll be in touch once there’s news about it.

Hey there,

Just wanted to post an update that we have reproduced this issue. We’re currently looking into it. I’ll reach out once there’s an update on it.

1 Like

any news?

Hi Mark,

We’re still working on fixing this export issue. Meanwhile, you can work with the browser version of the ReachView 2 and with the ReachView 3 beta version.

To access the receiver via the browser on your iOS, just type the receiver’s IP in the address bar. You can check this guide for more details.

Hey everyone,

Just wanted to tell you that we’ve released a new stable v2.24.0 firmware version. It should fix the project export issue that you’ve experienced. You can find the full list of all fixes and improvements of the new version in this community forum thread.

It’d be great if you could update your receivers and share your experience with the update.

Thanks!