RS2 no longer sharing mobile data through hotspot

After the latest update the RS2 is no longer sharing mobile data via its hotspot.

We have made sure share data settings etc are on.

Please help

Same issue on two devices

What firmware are you running?

2.24.0 :slight_smile:

Hi @hairyape1,

Sorry for the delay!

We couldn’t reproduce this issue with our SIM cards. Usually, mobile data sharing can be activated if you enter your service’s APNs.

Could you specify if you successfully worked with this SIM card before?

It’ll be great if you shared the Full System Report on your device with us while the SIM is inserted. The logs in the Full System Report will help us to analyze why the mobile data can’t be turned on. Please send it to me in PM or to

Hi Polina, Sorry for my delay too, last week went manic.

I can confirm that the sim worked originally before updating to 24.0. The same behaviour was seen on our other device (both using a sim from the same network (EE in the UK).

I will get a system report over to you this week.


1 Like


Thanks for the clarification!

If possible, it’d be great to see the reports from all devices you faced the issue on. This will help us to collect as much information as possible about the issue and resolve it.

Hey there,

I just wanted to let you know that we have just released the new dev firmware version v2.25.2. It should resolve the issue with the Mobile data not being able to switch on. You can check all fixes and improvements in this community forum thread.

Please note that dev versions are mainly meant for early access to the new features. They are not intended for the important fieldwork.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.