RS2: I can't switch to ON in Mobile Data

similar problem like: Closed Post
I have a newest firmware and correct Sim Card witout SIMLOCK.

SIM: Orange, Poland
APN for Orange: “internet” or “internetipv6”, I tried also with an empty blank.
Firmware: 2.22.3, I tried it on 2.22.2.
Range: very good - full range on SIM and 40 satellites.
Still I can’t switch to Mobile Data On. (5 seconds gray and still OFF).

Hi @pkowalinski,

Could you send me the Full System report generated on your device in PM? Here’s how to get it.

I’d like to check on which step the connection stuck.

I’m from Poland.
I confirm the problem. Use a different card, T-mobile works.

APN internet enable roaming

Hi @pkowalinski,

Have you had a chance to try recommendations from above? Is there any chance you managed to resolve it?

Ok I resolve a problem. I don’t know how. In next day the switch was at ON.
I was working on it few days and I had about 1-2 reset per day. I had to turn on my wifi and switch to ON. It is a little problem but it works :slight_smile:

Hi Kowal,

Glad to hear it solved!

May I ask you to clarify if you lose the connection with Reach hotspot in such cases?

Yes. I use RTK to measure fields. Yesterday I used it to collect 7 points.
When I measure fields I have receiver on my car’s roof. Sometimes I need GPS for 2-3 hours (sending to my computer by BT). Very often EMLID loses RTK and I have to turn on my wifi and switch Mobile Data to ON despite I have full range on my smartphone (the same operator - Orange).


  1. When I need it to few points it works good.
  2. When I need GPS for few hours it works bad.

Hi @pkowalinski,

Could you share the data recorded during these tests (raw data log, position log, base correction log)? You can download them in the Logging tab.

I’d like to look into this case more thoroughly, as it doesn’t look like a normal Reach’s behavior.

Here you have all files from 2020-04-01 (whole day worked).
Files from 2020-04-01

Good luck :slight_smile:

Hi @pkowalinski,

I have checked the data. There were logs from 2 surveys: in one of them, there were no losses in correction data. However, I’ve checked another one, and it seems there are some gaps in RTCM3 messages:

I assume it may be caused by the fact that you re-enabled mobile data on the receiver.

In the dev v2.23.4 firmware version, we’ve added some improvements on how Reach RS2 handles the RTCM3 messages it accepts from NTRIP casters. I believe it should improve your workflow with Reach RS2, too. This improvement will make it into the next stable branch, and you can either test the dev release or wait until the stable is out.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.