RS2 Field Genius Bluetooth issue

  1. Firmware image: version 27 and ReachView version 3.
  2. [System report] Below
  3. Detailed problem description. How does observed behavior differ from the expected one?
  4. Your step by step actions.
  5. Picture of the setup and connection scheme.
  6. If using any additional hardware please provide exact make and model.

When trying to add a new instrument profile in Field Genius version 1.8.2.5720 on my Android P300PRO tablet, I get to “Set up Communication”, I hit “Search”, and Field Genius is not able to find my RS2 receiver.

In Reach View, I have the receiver’s Bluetooth turned on and discoverable. I have Position Output set to Bluetooth ERB.

If I go to the Bluetooth settings on my tablet, I can see the receiver and pair with it, but for only about 3 seconds before it unpairs.

However it seems that the receiver has no problem pairing with my Android phone.

I have a second RS2 receiver that connects to Field Genius via Bluetooth just fine and both receivers are set up the same in Reach View.

[Edit] also in Reach View, both receivers report that they are paired with the P300PRO tablet.

System log:

Simple system report
app version: 27.0-r4
current_network:
  ip: 192.168.1.182
  security: wpa-psk
  ssid: ATT7447
enabled: true
mode: client
base_mode:
  base_coordinates:
    accumulation: 120
    mode: fix-and-hold
  output:
    io_type: 'off'
    settings:
      cloud:
        mount_point: ''
      lora:
        air_rate: 18.23
        frequency: 902000
        output_power: 20
      ntripsvr:
        address: ''
        mount_point: ''
        password: '***'
        port: -1
      serial:
        baud_rate: 38400
        device: ttyEXTS0
      tcpcli:
        address: localhost
        port: 9001
      tcpsvr:
        port: 9000
  rtcm3_messages:
    message_1004:
      enabled: false
      frequency: 1
    message_1006:
      enabled: true
      frequency: 0.1
    message_1008:
      enabled: false
      frequency: 0.1
    message_1012:
      enabled: false
      frequency: 1
    message_1033:
      enabled: false
      frequency: 0.1
    message_1074:
      enabled: true
      frequency: 1
    message_1084:
      enabled: true
      frequency: 1
    message_1094:
      enabled: true
      frequency: 1
    message_1124:
      enabled: true
      frequency: 1
    message_1230:
      enabled: false
      frequency: 0.1
bluetooth:
  enabled: true
  pairing:
    discoverable: true
    pin: '***'
correction_input:
  base_corrections:
    io_type: ntripcli
    settings:
      bluetooth:
        send_position_to_base: false
      cloud:
        mount_point: ''
        send_position_to_base: true
      lora:
        air_rate: 18.23
        frequency: 902000
        output_power: 20
        send_position_to_base: false
      ntripcli:
        address: 198.202.228.109
        mount_point: RTX_RTCM31
        password: '***'
        port: 2101
        send_position_to_base: true
        username: RHW
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        send_position_to_base: false
      tcpcli:
        address: localhost
        port: 10001
        send_position_to_base: true
      tcpsvr:
        port: 10000
        send_position_to_base: true
device:
  power_on_bottom_connector: false
  privacy_policy_accepted: true
  role: null
  rv3_banner_shown: false
  usage_analysis_accepted: false
logging:
  logs:
    base:
      autostart: false
      format: RTCM3
      started: true
    correction:
      autostart: false
      format: RTCM3
      started: true
    raw:
      autostart: false
      format: UBX
      rinex_options:
        logging_interval: 1
        marker_name: null
        pole_height: null
        satellite_systems:
          beidou: false
          galileo: false
          glonass: false
          gps: true
          qzss: false
          sbas: false
        time_adjustments_enabled: null
      started: true
    solution:
      autostart: false
      format: LLH
      started: true
  settings:
    debug: false
    interval: 24
    overwrite: true
network:
  tcp_over_modem: false
position_output:
  output1:
    io_type: bluetooth
    nmea_settings:
      bluetooth:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpcli:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
    settings:
      bluetooth:
        format: ERB
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        format: ERB
      tcpcli:
        address: localhost
        format: ERB
        port: 9000
      tcpsvr:
        format: LLH
        port: 9001
  output2:
    io_type: 'off'
    nmea_settings:
      bluetooth:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpcli:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
    settings:
      bluetooth:
        format: ERB
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        format: ERB
      tcpcli:
        address: localhost
        format: ERB
        port: 9000
      tcpsvr:
        format: LLH
        port: 9001
positioning_settings:
  elevation_mask_angle: 15
  glonass_ar_mode: false
  gnss_settings:
    positioning_systems:
      beidou: true
      galileo: true
      glonass: true
      gps: true
      qzss: true
    update_rate: 1
  gps_ar_mode: fix-and-hold
  max_horizontal_acceleration: 1
  max_vertical_acceleration: 1
  positioning_mode: kinematic
  snr_mask: 35
sound:
  mute: false
  volume: 100
1 Like

Hi @mouser98,

In most cases, difficulties in the Bluetooth setup occur if something goes wrong during the configuration. I’d suggest going through the setup once again to make sure there are no issues with that:

  • Go to the ReachView 3 settings and drop them to default

  • Setup the connection between Reach RS2 and FieldGenius as described in this guide

If it doesn’t help, please share a screencast of the described behavior and the Full System report from your Reach. It will allow me to get more detailed information about the receiver’s performance. You can download the report from Settings -> General -> Troubleshooting -> System report -> Full report. Please note that the report may contain sensitive information, so it’s better to share it via support@emlid.com.

1 Like

Try setting the Bluetooth position output to NEMA

1 Like

Changing Bluetooth position output to NMEA didn’t change anything. Sent full system report to emlid.

Hi @mouser98,

Thank you! I’ve answered you via email since we’ll need a Full System report from the second Reach RS2 device to compare the receivers’ performance.

1 Like

A post was split to a new topic: RS2 and FieldGenius BT connection issue

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.