RS2 and FieldGenius BT connection issue

I am experiencing a similar issue today using almost the exact same setup even though I have been enjoying trouble free usage despite software & firmware upgrades over the past 1+ year.
The setup remains unchanged since last week when the set up worked perfectly.
Today, for some unknown reason FieldGenius refuses to speak to the RS2 Rover unit.

Hi Adrian,

I see that you refer to another thread with a similar issue, but please confirm some main points:

  • The tablet does see Reach but can’t pair
  • Reach is on the latest firmware version, 27.1
  • What Android tablet model and OS version do you use?

I also received the report via email, thanks! I’ll check it, but also want you to try suggestions that Kseniia wrote in the thread:

  1. Check if it works with NMEA output
  2. Try to reset Reach settings to default
  3. If it’s possible to pair Reach with the tablet, can you check the connection with the Lefebure app?

Hello Svetlana,
Thanks for your timely response. In answer to your questions:

** The tablet does see Reach but can’t pair*

The tablet does see Reach and it does pair in BT, however, in the Fieldgenius app, there is no communication nor connection with Reach

** Reach is on the latest firmware version, 27.1*

That is correct - I tried to proceed before (27) & after upgrading to 27.1

** What Android tablet model and OS version do you use?*

Tablet is Cedar CT8 (supplied by Microsurvey/Fieldgenius)
Android version 8.1.0
Fieldgenius version is

I believe the issue is related to the fact that Reach will not broadcast BT output in ERB format
Reach refuses to update to this format.
Before yesterday, Reach had been communicating fine with the Fieldgenius app
No known changes were made between states of connection & non-connection

I will try your suggestions later this evening


Hi adrian.levy99,

I leave you one of the links where you can see fieldgenius information for the connection. Sometimes Bluetooth may have problems( on- off Bluetooth), it has happened to me, I have only performed the pairing again, always having the corrections output active in ERB format

1 Like

I had a similar issue in the past with RS2 BT communication with Survey123 using Android. What fixed the problem immediately was to disable the mobile device’s WiFi connection (and Hotspot) to the RS2.

1 Like

Thank you

Thank you.
Will try that suggestion.
Have you ever observed occasions with the wifi on the Reach unit cutting out?

We had similar issue. Sometimes, when we use sim card + hotspot + Bluetooth, the bluetooth connection was not stable. Sometimes, the Reach device could not connect to the hotspot.

1 Like

Hi Adrian,

It’d be nice to know if any of the users’ or mine suggestions help you out!

We noticed that somehow the bluetooth on Reach device was turned off by itself and we needed to manually turn it on to make it work with app like SurvPad.

Hi Svetlana
I visited the Fieldgenius (Microsurvey) website this evening and downloaded an updated version of the software. Everything is good now.

1 Like

Hi Adrian,

That’s great! It seems some internal changes were made. Good to know, anyway.

1 Like

Hi All,

I’ve been using FieldGenius for over a year with no problems. I just updated to V2.0 and all heck broke loose. Too many problems and terrible BlueTooth communications.

Here is the official response from Field Genius Tech Support.

This is Chris from MicroSurvey Support.

I got a message from Curtis, you were having all sorts of issues with the FieldGenius for Android version 2.0

But I think the issue with the version 2.0 might be related to some files not updating correctly.

We can try clearing those out and trying the version again:

- Backup your project files from your Android device.

- Uninstall FieldGenius for Android

- Delete the FieldGenius folder on your device

- Reinstall FieldGenius version 2.0

P.S. The reply from the FG tech came late last night and I haven’t tried the “fix” yet, so good luck.



This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.