RS2 connection problems Wifi with Android (hotspot mode)

Hi,

I updated to 2.24.2 Firmware. I was not be able to stablish a connection between my Android phone and the RS2 (in hotspot mode). Tried a lot of times with 2 different Android phones and 2 different RS2 antennas. This is the error message:

Android 1 connecting Base

Android 1 after about 2 minutes trying to connect Base (can’t connect to receiver)

Android 1 Rover detected

Android 1 after about 2 minutes trying to connect Rover (can’t connect to receiver)

Tried with a different Android phone:

Android 2 connecting Base

Android 2 after about 2 minutes trying to connect Base (can’t connect to receiver)

If I connect RS2 and Android phone to my local Wi-Fi, it is OK and I can connect to RS2.

The problems are when trying to connect with Reachview3 (latest version) and Reachview2 in hotspot mode. If I use a laptop I can connect in hotspot mode.

I think I’m going to back to 2.24.0, since I have not had this problem before. And I need to be able to connect in hotspot mode to use RS2 in the field (no wi-fi available)

Any ideas? Is this a issue related to Firmware 2.24.2?

As a curiosity, yesterday I received my second RS2 receiver, but still not be able to test RTK on the field because of this :pensive:

Hi @Doppler_Uav,

Can you try disabling mobile data on your Android device and check once again?

Hi @tatiana.andreeva,

If I disable mobile data I can connect to RS2.

Tried different times. Sometimes the RS2 does not appear in the “receivers” list but it connects, I can see on the “status” that is connected.

Is this something that will be corrected in the next update? I can connect right now if I disable mobile data, but would be good If I can have it enabled while using Reachview3.

Thanks

Hi @Doppler_Uav,

Before drawing any conclusion on it, we need to look into why it happens. Once we come to an understanding of what’s the root of this behavior, we will able to provide you with the solution.

For it, we need the Full System report generated on the Reach RS2 device when it’s in a hotspot mode. Please send it to support@emlid.com as it may contain sensitive info.

Hi @tatiana.andreeva,

I found a solution: enable mobile data after connecting to RS2 (in hotspot mode).

1-Disable mobile data on Android phone
2-Power on RS2 in hotspot mode.
3-Open Reachview3 on android phone and connect to RS2
4-Enable mobile data on phone.

Thanks!

Hi @Doppler_Uav,

Thanks for sharing it with us. Anyway, we’ll look into why it behaves that way.

1 Like

Hi @Doppler_Uav,

Could you clarify which Android version you use? We assume it might be important for troubleshooting.

Hi @svetlana.nikolenko,

It is Android 9.

I am having similar issues with 2.24.0, was hoping 2.24.2 would help :smiley:

@artem.fomenko this helps explain some of our issues

Hi @Doppler_Uav,

If you could also share the Full System report from your Reach RS2 in a hotspot mode, it would be of great help. As Tatiana said above, it’s better to send it to support@emlid.com as it may contain sensitive info.

Hi @hairyape1,

Have you had a chance to update your device to v2.24.2?

Hi, I managed to check today, no improvement in behaviour :confused:

I have made a video of some of the problems to help explain, I will send via message.

Hi @hairyape1,

Did I get correctly that you tried both ReachView 3 and ReachView 2? What Android version do you use?

If possible, please generate the Full system report on your device and share it in PM.

Hi @Doppler_Uav,

We’ve thoroughly examined the Full system report you sent but couldn’t found out any malfunctions from the Reach side. It seems to be just the way some Android devices work. And we can barely fix that.

Thank you for sharing a workaround once again! It might be of much help for other users.