RS2 can't be seen in RV3

I am sitting in front of my fiber optic Internet CLARO router and the RS2 always to hotspot mode instead of connecting to the wifi previously paired to.

It is really a serious drag this issue of ReachView 3 and RS2 terrible connectivity I have 3 different brand of smartphones with Android 10, 9 and 8 and in all 3 the ReachView 3 app simply doesnt “see” the RS2 when there are several wifi network detected

PLEASE FIX THIS BUG

1 Like

Hi @aholsteinson,

Could you please specify what firmware version your Reach RS2 runs on? What version is your ReachView 3 app?

Please note that Reach RS2 can connect to 2.4Ghz networks only. Have you tried connecting your device to other networks?

Do I understand correctly that while connected to the Reach’s hotspot you can’t see the device in the ReachView 3 app?

1 Like

Hi Polina until last night I had ReachView 5.4 and RS2 firmware 2.24.2

I connected to my wifi router 2.4ghz network (it only has this frequency) so it is a saved network but still the RS2 everytime it starts goes by default to hotspot mode. Also connected to my router in my office and the University wifi and saved their network in the ReachView3 app connected to the RS2 but same default to hotspot every time a restart or start the RS2 Seems like after connecting to hotspot doesnt check for saved networks and connects

Hi Polina

Just updated to 2.26.1 beta firmware the RS2 and ReachView3 to 5.5

The RS2 wifi connectivity issue still is present. On restart it went by default hotspot mode even though I had configured the RS2 wifi to connect to my CLARO wifi router network ok.

I reconnected manually again to my wifi router network the RS2 and also the smartphone and was able to measure some points only wifi (the BT is unresponsive with my HUAWEI P30 PRO OS10 even though it indicates it is paired to the RS2)

I turned of both the RS2 and the app. Restarted RS2 and ReachView3 and again the RS2 went to hotspot mode 3 meters away of the wifi router. The problem seems to be that the RS2 by default goes to hotspot before connecting to saved wifi networks nearby or connects to the smartphone data via bluetooth connection (which should be the primary connection for surveying)

Hope it helps to find and solve this issue.

Hi @aholsteinson,

Thanks for your patience!

Reach receivers do in fact start the hotspot when they can’t find the network. If the network was configured previously and is available on the start-up of the unit, Reach should connect to it.

Does the issue persist if you move the unit closer to the Wi-Fi router? Usually, if the Wi-Fi is transmitted strongly and stably, the unit should be able to find it.

Could you please elaborate on it? What application do you use? What data do you transfer via Bluetooth?

1 Like

Hi Polina

The RS2 goes to hotspot no matter what every time I restart both RS2 I have even at 1m from wifi router. Have to manually conect to the hotspot and then select stored wifi network.

In ReachView 3 version 5.5 the BT indicates that it is paired to my HUAWEI P30PRO and RS2 but ReachView 3 doesnt share the mobile data from the smartphone to RS2

@aholsteinson,

Would it be possible to share the Full System Report from the unit with me in PM or via support@emlid.com? This report contains sensitive information so it’s better not to post it publicly.

To share the Internet from your smartphone to Reach, you need to connect Reach to your smartphone’s hotspot and enable mobile data on it. Bluetooth connection is used only as a way to transfer the corrections and to output the position. It can’t be used for configurations of the unit.

Once you connect to the stored wifi network, does it connect? Not knowing your knowledge of networking etc., and not trying to insult your intelligence but, did you type the SSID (network name) or select it from a drop down list? SSID’s are case sensitive.

Mobile data is shared from your phone to each individual device. If you go to your hotspot settings, you should see a connected device area that tells you what is connected to your hotspot.

Usually BT is used for sharing NMEA data out of the RS2 to your phone/tablet or other device.

1 Like