RS2 Base -> Topcon rover, has anyone got this working?

So I’ve looked at a few other posts, and I previously made a post about trying to get a Dozer connected to our RS2 through the Emlid nTrip caster.

Since that point, I have done some more testing.
The TL:DR is: No change in results.

Things I have done:
I was able to borrow a Trimble TDL 450H to push out a 450mhz range radio signal.

  • The result was unchanged, I was able to get a fix on the dozer for ~10-15 minutes. Then it would lose fix for a similar time.

I also tried the nTrip caster with a Topcon Hiper VR.

  • The results were the same. 10-15 minutes of solid fix, then it would float for 10-15 minutes and get a fix again.

I tried multiple different settings for the RTCM3 messages

  • Legacy or not, the results were exactly the same.

Our RS2 nTrip base station has been in place for almost the entire season at this point, it has worked almost flawlessly and gets great results when I connect using the RS2.

Originally I thought this was an issue on the Topcon end of things. But at this point, the newest Topcon rover with all the constellations has exactly the same results.

So has anyone else gotten a reliable -all day- fix using an RS2 as a base?

Sadly it seems that topcon products are highly dependable upon L2P which is not tracked by the Ublox chips, and likely never will be.
The L2P signal is being replaced by L2C which is much better in so many regards, so highly doubt that we will see L2P on ublox chips ever. As a fix between rs2’s usually work very nice, ublox (and Emlid down the road) hardly have business to gain by adding L2P, as that would just cause older units to stay in the field longer, not being replaced by i.e. an RS2.

I was fighting with similar issue with M2 base over ntrip caster and novatel(old) + hemisphere(new) rover for a long time. In my situation it worked for random time (10min to 30min usually) and suddenly rovers revert to single solution.
I did a factory reset and firmware update in all equipment and since then they work great without interruptions. Right now I am on firmware 27 and not updating to 27.1 because it may stop working.
I don’t know about topcon receivers but I think they are more strict about 3rd party equipment.

Hi there,

Indeed, @vgo195 faced pretty similar behavior with their Reach M2. I remember this case. And I can confirm that 27 firmware version fixed things. So, Grant, what version do you work with?

Also, @vgo195, 27.1 works the same as 27 in terms of RTK. So, it should work for you as well. If it doesn’t, we’ll get back to our investigation.

I was running 27.1.

I am currently updating to 28. Though I have not seen the patch notes.

@wizprod I don’t think anything to do with L2P is broadcast on a standard nTrip server or Base station.

Right now there is no real reason emlid shouldn’t be able to match a normal base station broadcast. I really don’t know what is different, but obviously it’s on the Emlid side and not Topcon.

Ublox f9p isn’t tracking GPS L2P and older gear can’t use L2C, so you are essentially stuck with a L1-only fix.

You have 2 options:

  • replace the legacy equipment with an RS2 or M2 with your favorite antenna, as it is probably overdue anyway (preferred, it you control client purchase)
  • use a base that can broadcast L2P as well as all the other obs-types.

The Topcon Hyper VR is brand new and can use L2C, so your suggestion is not the problem.

How is it configured? To receive standard rtcm3 msm messages?

Hi Grant,

Does the issue persist with the 28 firmware version? Maybe the Topcon supports recording corrections coming from the Reach? It would be very helpful.

Also, I’m +1 to Christian’s question. Does the Topcon require legacy RTCM3?

@wizprod The Topcon receivers work with the standard RTCM3 messages or the legacy ones. The loss of fix after 10-20 minutes is observed either way.

I don’t have the Hyper VR to test with anymore (it was on loan). And unfortunately there are no settings or logs I can access on the Topcon bulldozer.

Hi Grant,

I got you. Please give us time to conduct some tests on our own, and I’ll get back to you.


So we just bought a brand new John Deere 872GP grader. A quick test yesterday had the same results.

1 Like

I see it’s a reproducible issue. We’re checking it and already have some assumptions. I’ll be back with the news as soon as I have them.


Looking forward to the verdict!

1 Like

Have you had any results from your testing yet?

If it is possible to get this working around March/April for the start of the season, that would be great for us!

1 Like

Any chance running commercial topcon corrections through snip?

There may be an added “security” message, that is missing.

Can the topcon take Trimble corrections?

Can you elaborate on that part? What is it sending?

I’ll have to look into snip.

As for topcon/trimble. They work interchangeably currently.