RS2 and Autel Evo 2 pro RTK

Good day everyone, I wanted to ask if by chance anyone has already used the RS2 together with the Autel Evo 2 pro rtk. And if so, I wanted to know if they are compatible and how it works to get rtk or ppk fixes in case there is no Ntrip network. Thank you

Drones with RTK at this point cannot get corrections from 3rd party receivers so NTRIP is your only choice unless you have the drone manufacturer’s base.

Grazie per la risposta.
Facevo questa domanda perchè il rivenditore dell’Evo 2 pro rtk mi ha detto testualmente:

“Il drone si connette in A-RTK via protocollo RTCM 3: usa la WiFI della base station e da li riceve via RTCM le correzioni”

Quindi pensavo che siccome il RS2 trasmette i dati in RTCM3 potesse essere compatibile con l’evo2 pro rtk come base station

I think it has moreso to do with the LoRa radio connection.

Please keep conversations to English, so everyone can follow without needing to translate.


sorry, I thought he did the translation automatically.

I put back the question with translation

I was asking this question because the Evo 2 pro rtk dealer told me verbatim:

“The drone connects in A-RTK via RTCM 3 protocol: it uses the WiFI of the base station and receives corrections from them via RTCM”

So I thought that since the RS2 transmits data in RTCM3 it could be compatible with the evo2 pro rtk as a base station

Hi Marco,

Sorry for the delay!

We’ve never tested Reach RS2 and Autel Evo 2 Pro RTK integration. However, Reach RS2 indeed transmits data in RTCM3 protocol and supports NTRIP protocol. You can check the list of outputted RTCM3 messages here. If this drone supports them as well, there should be no issues with such type of integration.

I have the Autel RTK Drone and it only works via NTRIP at the moment.

Emlid caster wont work as the Autel explorer software will not allow you to input your own Mount Point name and forces you to use one of a select few.

It does NOT record an independent data file (it create a RINEX log but its blank). As is the case, this drone wont even allow a PPK workflow.

Autel hasn’t released its own base, not that you would need one if youre here in the emlid forums).

So the only way to get the Autel RTK drone to work in a proper workflow is to setup your own NTRIP caster, be lucky enough to live in an area that has public NTRIP available, or fly WITHOUT RTK/PPK functionality (normal GPS function).

I would get in with them and work on the inability to PPK and setup a mount point. If you are a serious mapper they should be pretty acceptant. There are very few people actually using this drone for RTK so everyone will start finding this missing features and they will adjust moving forward.

I would also suggest getting on the DroneDeploy forum and looking for JMason702. Here is a recent post of his. You might mention MichaelL referred you.

I agree with madpuma13.

I’ve got an Autel Evo2 RTK that I thought I could use with my Emlid RS2. The Emlid system has been quite solid and the (current) problem appears to be with the Autel Explorer software. The screen where you put in the RTK NTRIP info seems very “young” aka buggy. I’m going to try to pressure Autel to fix it. I’m trying to use the Emlid Caster, and the Autel Explorer has a pick list for Mount Point that is super flaky. It kept remembering a previous NTRIP site I used and showing the Mount Point picklist from that site. So I uninstalled the Autel Explorer app to clean that list out. Which it did, but it would not re-populate the list nor would it let me enter my own Mount Point.

I’ll focus my energy on getting Autel to fix the app. The drone seems quite solid, though, and I like it.

If anyone else has learned anything, please share!

1 Like

Another pilot on a different forum that I chat with has had similar issue with the NTRIP profile in Autel Explorer and the reinstall has fixed his but it sounds like yours also will not auto-populate the mountpoint created by the Emlid Caster either? We haven’t had any issues over 3 completely different types of hardware so I agree that Autel needs some more field testing. Great drone!

Hi @madpuma13, @mark5,

So, does Autel software only allow pick up the mount point from a drop-down list? And there is no such a list when you’re connected to Emlid Caster? I’m trying to understand if we can do something from the Caster side to help you with this.

Hi Svetlana! Correct. The Autel Explorer software has a picklist for Mount Point. It apparently gets the values from the NTRIP site. For example in the state of Oregon, we are lucky to have a state-run NTRIP service and when I connect with my credentials, it populates the picklist with the Mount Points that are available in Oregon.

I don’t know anything about the NTRIP API, etc. but there must be some request that passes back the Mount Points to the client software. If Emlid Caster could support that request then we could get around the (current) limitation in the Autel software.

Thanks for taking interest in this! Emlid rocks.


Dang, I here I was thinking that Autel would be my next drone vendor for an RTK/PPK drone. Guess not :frowning: would really like a solid DJI alternative…

1 Like

That’s correct they only allow from a drop down list. I’m not quite sure how they determine what the mount point names are, however.

I’ve set up my own ntrip stream on my network using SNIP and the Autel explorer app has a different set of mount point names after it connects to my server but I didn’t put any of the names in the deep down list as available.

I have to go back and modify the server settings to a mount point name that is listed on the drop down menu in order for it to work.

The only way for the Emlid caster to work with Autel, in it’s current state at least, is to have the option to make our own mount point name to one that is in that drop down list.


Me too but software ecosystem strikes again! The Evo II Pro 6K should have been the P4P mapping killer. I mean it still kind of is but not at scale commercially. People like us can wiggle around it but no way I am deploying to my pilots and waiting for the problems to hit my phone.

I actually like the Autel RTK drone very much. It seems very solid and feels less like a toy than some of the DJI rigs I’ve had. For the NTRIP in Oregon, it’s great. Flying in other states hasn’t been as slick because of these software issues. And having an empty RINEX file is a real bummer. From my testing, the GPS accuracy without RTK or PPK is pretty darned good. I can use my Emlids to place good GCP and Checkpoints, and get some great accuracy even with the stated software issues.

I feel like it’s really close to being the Promised Land and if we rattle some cages they will get the software cleaned up.

I had a conversation with an Autel Tech Support person, and he didn’t really seem to know what I was talking about with Mount Points and empty RINEX files. But he took all my details and said he would pass it on to “his engineer” and will be getting back to me. I tried to stress how important this was for doing detailed mapping.

1 Like

It seems Autel needs to fix the problematic NTRIP client they have.
Your options for running your own caster are

  1. emlid caster (very solid)
  2. (good but needs registration and it is not guaranteed that will work forever)
  3. SNIP caster (you must be very technical to set it up)
  4. Lefebure NTRIP caster (discontinued but the last time I used it back in 2018 it worked. The downside is that you must have static ip or use a no-ip subscription)
    The emlid caster is the best option IMO but I have a little suggestion. While populating the mounpoint list is there a posibility to show only my Mountpoints instead of all available?
    For example when I connect to the caster it shows over 30 mountpoints but I can connect only to my registered Mpts.

P.S. Does Autel drone has mechanical shutter? I am also looking for a P4Pro alternative for RTK/PPK mapping.

No, it’s electronic.

Hi @mark5, if there was any update from Autel? Whether now is custom NTRIP option available? If the writing of pos files was corrected?