Rs+ wifi not stable

Hi there
Lately im having some issues with my pair of rs+ connection via wifi not stable it keeps connecting and disconnecting and sometimes it will not connect in emlid flow app it keeps prompting the message “can’t connect to receiver” and one other thing last time I used rtk the rover is receiving correction but will not show the baseline

Hi @bencheikhbaker,

Please ensure that your Wi-Fi network uses a 2.4GHz band and that your RS+ and Emlid Flow are running the latest update. Try removing the Wi-Fi network from your Saved Networks list and then reconnecting.

If you’re still experiencing issues, let me know:

  • Can you reproduce the issue on another Wi-Fi network?
  • Can you connect Reach to the internet via a mobile hotspot?

Regarding not seeing a baseline in Emlid Flow, can you share a screenshot of what you see in the app?

Now it’s even worse every time I connect to a router or a hotspot from a phone it saved it and display out of range signal

That’s unfortunate that you can’t connect to the RS+, let’s see what we can do.

Can you tell me if you were able to test my previous suggestions? Removing the Wi-Fi from the Saved Networks list and testing the connection with another Wi-Fi.

Please also send a Full System report to us at

1 Like

I tested with 2 phones a laptop and new router when i unsaved them will not show up on network available the only hotspot will find and connect to is an old LG phone that I remember i used the first time I setup when I purchase the pair
Yesterday using the LG i upgraded to the new update thinking maybe will solve the problem but nothing change

I’d like to go through your workflow and confirm a few things:

  1. Both of your RS+ can’t connect to the Wi-Fi broadcast from the router.
  • Can you confirm that the Wi-Fi network is using a 2.4GHz band?
  • Have you tried another Wi-Fi network?
  1. Both of your RS+ can’t connect to the mobile hotspot except one LG phone.

What was the mobile platform of the other device you checked? iOS or Android? We have a support tip on what to check if you can’t connect Reach to the internet via a mobile hotspot.

  1. When you try to add a network again, it doesn’t appear on the Available screen in the Emlid Flow application.

What happens when you try to add a hotspot or Wi-Fi manually?

P.S. I’ve also deleted your answer with a Full System Report as it contains sensitive information.

1 Like

Yes both receivers will not connect
Yes I made sure I’m using 2.4 GHz
No i didn’t try another network
Yes both receivers only connect to the LG phone
Yes i tried adding hotspot manually and nothing change the same problem

Thank you for this information.

I’d like to continue our investigation via email as the next troubleshooting steps are easier to handle there. I have sent you an email.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.