RS+ serial USB-to-PC linux no data

Hi everyone,

Software version v2.24.2

I have plug my reach RS+ using the USB cable to my computer which is running under ubuntu 18.04.
I have configured the output number 1 using reachview app.
Screenshot from 2021-01-26 18-46-01

I can see on my linux that there is a new device :
[ 3370.197311] cdc_acm 1-2:1.2: ttyACM0: USB ACM device

but when I try to see the incoming data using cat or minicom I get nothing
sudo cat /dev/ttyACM0
sudo minicom -D /dev/ttyACM0 -b 115200

I also tried the walkthrough with serial tester but I get nothing.

I have 2 reach RS+ and I have the same behaviour. I want to do a rover/base system and collect data with my linux.

System report:

Simple system report
app version: 2.24.2-r0
'wifi_status, interface: wlan0':
- wifi_mode: infrastructure
- ip:
  is_added: true
  is_connected: true
  is_visible: false
base mode:
  base coordinates:
    accumulation: 2.0
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    - 0
    - 0
    - 0
    format: llh
    mode: single-and-hold
    baud_rate: 38400
    device: UART
    enabled: false
    io_type: serial
  rtcm3 messages:
      enabled: true
      frequency: 1.0
      enabled: true
      frequency: 0.10000000000000001
      enabled: true
      frequency: 1.0
      enabled: false
      frequency: 1.0
      enabled: false
      frequency: 1.0
      enabled: false
      frequency: 1.0
      enabled: false
      frequency: 1.0
  discoverable: false
  enabled: false
  pin: '***'
    - - 863000
      - 870000
correction input:
    air_rate: 9.1099999999999994
    enabled: true
    frequency: 868000
    io_type: lora
    output_power: 20.0
    send_position_to_base: false
  night_mode: false
  power_on_bottom_connector: false
  privacy_policy_accepted: true
  usage_analysis_accepted: false
    format: RTCM3
    started: true
    format: RTCM3
    started: true
  debug: false
  interval: 24
  overwrite: true
    format: UBX
    started: true
    format: LLH
    started: true
  air rate: 9.1099999999999994
  frequency: 868000
  output power: 20.0
position output:
    baud_rate: 57600
    device: USB-to-PC
    enabled: true
    format: NMEA
    io_type: serial
    baud_rate: 38400
    device: UART
    enabled: false
    format: ERB
    io_type: serial
rtk settings:
  elevation mask angle: 15
  glonass ar mode: 'on'
  gps ar mode: fix-and-hold
  max horizontal acceleration: 1.0
  max vertical acceleration: 1.0
  positioning mode: kinematic
  positioning systems:
    compass: false
    galileo: true
    glonass: true
    gps: true
    qzss: true
    sbas: true
  snr mask: 35
  update rate: 5

Best regards

Hi Arobaz,

Thanks for the detailed description!

Could you please specify if the receiver is calculating a Solution during your tests?

It wasn’t because my two modules were outside but I tried it on the outside and it worked, I managed to received the data using
sudo minicom -D /dev/ttyACM0



Thanks for the update! On the stable versions, it’s necessary for the unit to have at least a Single solution to be able to output the position data.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.