RS+ fails to update to v2.23.9

I want to try Reach View 3 BETA but I can’t update to the dev version, “Failed to perform update”. The update downloads but it won’t install.

Tried multiple times, multiple routers, multiple restarts.
The unit is an RS+.
Can the dev versions be flashed using the pc or do you have any other suggestions?


There’s no easy way to do what you’re asking to do. But I’m pretty sure we’ll come up with another solution.

Could you please tell what version you’re updating from?

In order to understand why the update fails we might need to get a little more information. Could you please share the Full System Report after you see this issue? Just try updating one more time and then edit the address bar to contain only the IP of your Reach by erasing the trailing “:5000”. This report would be of great help.

Hi @Iosif,

Great to know you successfully updated to the v2.23.9 in the end!

Thanks for the report. I’ll delete your comment with the report as it might contain some sensitive information.

We’ll check the report so that we could find the cause of the issue with the update.

Hey there,

It seems like the issues with the Internet connection might have caused the updating failure. The unit couldn’t download the image straight away. However, once the connection became stable the next day, Reach RS+ successfully updated.


Thanks for sharing. It was a bit weird because the download always started and downloaded well to at least 30%. Good to know.

Thanks for your feedback!

1 Like

Hello, today I tried to update RS2 from 2.23.6 to 2.23.9 but it “Failed to perform update” so then I used the reflash tool to reset the device to factory defaults and it was a success, so now I have stable 2.23.7 and still can’t update to 2.23.9… it is annoying.

Is it possible to download the image of 2.23.9 for rs2 and do it using a reflashing tool?

Hello all were your devices outside when trying to perform a update?

A post was split to a new topic: BT issues on v2.23.9

Hey there,

We’re now checking what could be the issue with the updating process. I’ll reach out once there’s news about it.

@cmielewski, please check your PM. I’ve written to you there.

Hey guys,

We’ve fixed our unit’s updating. Now it should be possible to finish the process without any issues.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.